TI: SIGTRAP with catch/yield

RESOLVED DUPLICATE of bug 646267

Status

()

--
critical
RESOLVED DUPLICATE of bug 646267
8 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
The following testcase causes a trap on TI revision d78eef12a329 (run with -m -n -a), tested on 32 bit:

function expectThrowError(errorCtor, fun) {
    try {
        fun()
    } catch (e) {}
}
function expectThrowTypeError(fun)
expectThrowError(TypeError, fun);
expectThrowError(SyntaxError, function () {});
expectThrowError(SyntaxError, function () {});
expectThrowError(SyntaxError, function () {});
expectThrowError(RangeError, function () {});
expectThrowTypeError(function () { yield });
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646267
(Reporter)

Updated

7 years ago
Blocks: 676763
(Reporter)

Comment 2

6 years ago
A testcase for this bug was already added in the original bug (bug 646267).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.