Last Comment Bug 651226 - Add 'winxp', 'win7' and 'win8' to showfor
: Add 'winxp', 'win7' and 'win8' to showfor
Status: VERIFIED FIXED
u=user c=wiki p=3 s=2012.20
:
Product: support.mozilla.org
Classification: Other
Component: Knowledge Base Software (show other bugs)
: unspecified
: All All
: P1 normal with 1 vote (vote)
: 2012Q4
Assigned To: Mike Cooper [:mythmon]
:
:
Mentors:
: 714002 715441 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 13:43 PDT by James Socol [:jsocol, :james]
Modified: 2014-01-08 08:49 PST (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description James Socol [:jsocol, :james] 2011-04-19 13:43:52 PDT
Add 'winxp' and 'win7' operating systems to showfor. The current 'win' OS will continue to apply to all Windows versions; 'winxp' will apply to Windows XP; and 'win7' will apply to Windows Vista and 7.

(Random thought: maybe it makes sense to start including the relevant JS identifying regex in the Python where we define the available OSes?)
Comment 1 James Socol [:jsocol, :james] 2011-10-27 13:39:52 PDT
Michael: Is this still something we need?
Comment 2 Atul Varma [:atul] 2011-12-01 17:15:23 PST
Hey, I just added platform-specific videos demonstrating how to show the bookmarks toolbar for Firefox on Windows 7 and OS X:

  https://support.mozilla.com/en-US/kb/Bookmarks%20Toolbar/compare?locale=en-US&to=19179&from=18660

These videos were made by Richard Milewski, and he's got a corresponding one for Windows XP:

  http://videos-cdn.mozilla.net/serv/labs/hackasaurus/ToolBar-XP-FF7.webm

However, I guess we can't show this until this bug is fixed. No rush or anything, but just figured I'd mention it here. :)
Comment 3 Swarnava Sengupta (:Swarnava) 2012-01-29 18:02:51 PST
*** Bug 715441 has been marked as a duplicate of this bug. ***
Comment 4 Will Kahn-Greene [:willkg] 2012-03-15 10:08:27 PDT
Taking this out of Erik's queue.

I don't know the kb stuff very well, so I don't understand why this has been hanging around for a year now. Is this something that we need in the kb? Any idea why we were waiting to implement it?
Comment 5 Swarnava Sengupta (:Swarnava) 2012-03-15 10:11:09 PDT
(In reply to Will Kahn-Greene [:willkg] from comment #4)
> Taking this out of Erik's queue.
> 
> I don't know the kb stuff very well, so I don't understand why this has been
> hanging around for a year now. Is this something that we need in the kb? Any
> idea why we were waiting to implement it?

actually windows 8 not release officially yet, but consumer preview works very stable here, so if we start editing kb for windows 8, it will be very helpful
Comment 6 Verdi [:verdi] 2012-03-15 10:14:02 PDT
Let's wait on this for the moment. This needs some thought and discussion.
Comment 7 Verdi [:verdi] 2012-09-26 13:11:46 PDT
As discussed in last week's KB meeting https://etherpad.mozilla.org/kb-2012-09-20 , we should finally add these to Kitsune. Here are my suggestions for UI and markup:
UI:
Windows XP
Windows Vista/7
Windows 8

Markup:
{for winxp} = Windows XP
{for win7} = Windows Vista/7
{for win8} = Windows 8

Like James suggests in the description we should use the current {for win} to apply to all windows versions so that our current articles won't break and we can XP or 8 instructions as time allows.
Comment 8 Verdi [:verdi] 2012-10-05 08:05:31 PDT
(In reply to Verdi [:verdi] from comment #7)
Actually in the UI we probably want to list the Windows 7 & Vista choice as "Windows 7/Vista" instead of "Windows Vista/7" as I said in comment 7.
Comment 9 Kadir Topal [:atopal] 2012-10-05 08:24:28 PDT
I'm adding this to the current sprint, assuming that this it's close to a one liner. Let's reevaluate if that is not the case.
Comment 10 Ricky Rosario [:rrosario, :r1cky] 2012-10-08 03:31:03 PDT
This is more complicated than a 1pter as we don't currently do any OS version handling in showfor. And there is special logic that needs to be defined and implemented (I don't really know what "use the current {for win} to apply to all windows versions" exactly means). Let's try to define it:

If I have this in my wiki syntax:
{for win}Windows{/for}
{for winxp}Windows XP{/for}
{for win7}Windows 7/Vista{/for}
{for win8}Windows 8{/for}

What shows up in each of the following cases:
1- User selects Windows
2- User selects Windows XP
3- User selects Windows 7/Vista
4- User selects Windows 8

This is more like a 3pter as we the showfor js code is can be fragile. We'll need to add a bunch of unit tests for the new behavior.
Comment 11 Will Kahn-Greene [:willkg] 2012-10-09 06:55:17 PDT
Kadir: Does comment #10 mean this needs to get bumped out of the 2012.19 sprint? I think it does given what you said in comment #9.
Comment 12 Kadir Topal [:atopal] 2012-10-10 07:46:51 PDT
Ricky, answering your question.

In code:

1. {for win}Horse{/for}
2. {for winxp}Horse{/for}
3. {for win7}Horse/Vista{/for}
4. {for win8}Horse{/for}

What we display:

a- User has WindowsXP as OS
1a {for win}Horse{/for}= Horse 
2a {for winxp}Horse{/for}= Horse
3a {for win7}Horse/Vista{/for}= NULL
4a {for win8}Horse{/for}= NULL

b- User has Windows Vita or 7 as OS
1b {for win}Horse{/for}= Horse 
2b {for winxp}Horse{/for}= NULL
3b {for win7}Horse/Vista{/for}= Horse
4b {for win8}Horse{/for}= NULL

c- User has Windows 8 as OS
1c {for win}Horse{/for}= Horse 
2c {for winxp}Horse{/for}= NULL
3c {for win7}Horse/Vista{/for}= NULL
4c {for win8}Horse{/for}= Horse
Comment 13 Kadir Topal [:atopal] 2012-10-10 09:30:43 PDT
I just moved this out of the 19th sprint, since this is way beyond a 1pointer that I first expected. Let's see if we can further break this down, or otherwise address this bug in the next sprint.
Comment 14 Ricky Rosario [:rrosario, :r1cky] 2012-10-10 09:47:54 PDT
Note that {for win} is an option for markup but we users will only be able to choose winxp, win7 or win8 from the dropdown.
Comment 15 Ricky Rosario [:rrosario, :r1cky] 2012-10-15 06:47:23 PDT
I haven't told him yet, but :mythmon will be learning about our showfor code in order to increase our bus factor to 2.
Comment 16 Ricky Rosario [:rrosario, :r1cky] 2012-10-16 11:23:38 PDT
This article might help with how showfor is supposed to work:

https://support.mozilla.org/en-US/kb/how-to-use-for
Comment 17 Mike Cooper [:mythmon] 2012-10-22 09:14:36 PDT
PR https://github.com/mozilla/kitsune/pull/911
Comment 18 Mike Cooper [:mythmon] 2012-10-22 11:05:33 PDT
Landed in https://github.com/mozilla/kitsune/commit/36d7e3fcd515d8cdfefa58d3c8eb163f24b9004b.

Pushing to stage, but this isn't going to production until we get some more eyes on it.
Comment 19 Ricky Rosario [:rrosario, :r1cky] 2012-10-23 06:57:18 PDT
I just deployed to prod.
Comment 20 Swarnava Sengupta (:Swarnava) 2012-10-25 10:25:54 PDT
*** Bug 714002 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.