clicking on the browser does not bring it to the front...

RESOLVED FIXED

Status

()

RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: michelangelo, Assigned: ykoehler)

Tracking

Trunk
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
if the mozilla window is beind another one, cliking on the area where the web pages should 
show up does not bring it to the front

Comment 1

18 years ago
When another app has the focus (yellow tab) you can still select text and push
buttons in the Mozilla windows, it won't come to the front.
When clicking on the window tab/border or menu-item it will get focus and come
to the front.
This isn't standard behaviour of BeOS apps, you should first click on a window
so that it has the focus before you can select text, push buttons, etc.

Comment 2

18 years ago
beos
Assignee: asa → koehler
Component: Browser-General → XP Toolkit/Widgets
(Reporter)

Comment 3

18 years ago
you are correct about actually clicking on buttons and things, but clicking on any 
application, in any part of the window, should at least bring it to the front of the other 
windows, even though the buttons do not recieve the messages...

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
the modeline says indentations are 2 spaces. please follow it.
http://www-classic.be.com/documentation/be_book/The%20Interface%20Kit/Window.ht
ml#WindowActivated()
should we be handling WindowActivated() ?
Keywords: approval, patch, review

Comment 6

18 years ago
Timeless, thanks you for comments.

About coding styles, you are right.
But I'm very confused, because many styles are intermingled in this code.
So I followed the style around the point.
Additionally about this file, there are some patches which are not checked in.
So I thought the minimum amendment will be welcomed.

Next, the function WindowActivated() is a hook function for detection of activations,
and not to activate the Window. This function will never called unless we call Activate()
except for the case users click window title.

Normally, user's first click in non-active state is treated by the framework of BeOS,
and cause the activation of the window.
But in this code, we use B_WILL_ACCEPT_FIRST_CLICK flag for the construction
of windows. So first click is not treated by the framework.
And we shuold activate window as the need arises at MouseDown().

Comment 7

18 years ago
I've forgotten to write another solution.

We can create windows without B_WILL_ACCEPT_FIRST_CLICK.
But this way cause the problem when we create windows for menus.
(We need two clicks to select an item...)
But we can avoid this problem by using B_AVOID_FOCUS flag
for menu windows.

I can make another pach using this method.
I think this new version is more natural solution.

Comment 8

18 years ago
Created attachment 22774 [details] [diff] [review]
another solution

Comment 9

18 years ago
Attachment 22774 [details] [diff] is a patch of another solution.
We don't need previous 22625 anymore.

This patch contain an amendment against another bug.
B_NOT_CLOSABLE flag is that. If we don't use it,
menu object will disapper on user's Alt-W.

Comment 10

18 years ago
Attach 22774 has been checked in.  Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.