Unable to connect to internet sites, but can connect to intranet

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: alex-mozbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.204 Safari/534.16
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

At work, when using Firefox 4.0.1 beta, I cannot connect to any internet sites (ex google.com). I can connect to sites within my corporate intranet.  I did not have this problem with Firefox 4.0, and don't have the problem using IE or chrome.

There is no proxy set up.  I verified that no proxy was configured under "Internet Settings".  I also set the "No Proxy" setting in Firefox, with no change.

I tried in safe mode, and I also tried with a clean profile.  In both cases the behavior was the same.  I can connect to intranet sites, but not the internet.

Reproducible: Always

Steps to Reproduce:
1. Go to google.com
2. Firefox reports "Unable to connect"
3. Go to website on corporate intranet
4. Website loads successfully
Actual Results:  
Firefox cannot connect to an internet site.

Expected Results:  
Site should load.
(Reporter)

Comment 1

8 years ago
It has something to do with the firewall software installed on our systems (Symantec Client Security).  When I turn it off, Firefox is able to connect.  I verified that there is a rule enabling Firefox to connect to the internet.  It seems like the firewall is not recognizing Firefox for some reason.
Please remove that rule and add it again. Nearly all Firewalls have a checksum of the allowed applications and the Firefox one changed with the update.
The Firewall usually should recognize the update but sometimes that doesn't work and the result is that the Firewall just blocks the firefox.exe with a different checksum.

marking invalid as this is not a valid bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.