Fennec debug with GL layers crashes on assertion: "ABORT: Tiling not supported for this manager/layer type" at gfx/layers/Layers.cpp:219

RESOLVED DUPLICATE of bug 628566

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 628566
7 years ago
7 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
1. Make a debug build of Fennec for Android
2. Set layers.acceleration.disabled=false, layers.acceleration.force-enabled=true
3. Restart Fennec in GDB

Get this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 14627]
__libc_android_abort () at bionic/libc/unistd/abort.c:82
82          *((char*)0xdeadbaad) = 39;
(gdb) bt
#0  __libc_android_abort () at bionic/libc/unistd/abort.c:82
#1  0x807024a8 in mozalloc_abort (
    msg=0x464fdaa0 "###!!! ABORT: Tiling not supported for this manager/layer type: '!aLayer->GetTileSourceRect() || (LAYERS_BASIC == GetBackendType() && Layer::TYPE_IMAGE == aLayer->GetType())', file /home/bjacob/mozill"...) at /home/bjacob/mozilla-central/memory/mozalloc/mozalloc_abort.cpp:75
#2  0x8563eb0a in Abort (
    aMsg=0x464fdaa0 "###!!! ABORT: Tiling not supported for this manager/layer type: '!aLayer->GetTileSourceRect() || (LAYERS_BASIC == GetBackendType() && Layer::TYPE_IMAGE == aLayer->GetType())', file /home/bjacob/mozill"...) at /home/bjacob/mozilla-central/xpcom/base/nsDebugImpl.cpp:388
#3  0x8563e9fc in NS_DebugBreak_P (aSeverity=3, 
    aStr=0x860ebf9c "Tiling not supported for this manager/layer type", 
    aExpr=0x860ebfd0 "!aLayer->GetTileSourceRect() || (LAYERS_BASIC == GetBackendType() && Layer::TYPE_IMAGE == aLayer->GetType())", 
    aFile=0x860ebe68 "/home/bjacob/mozilla-central/gfx/layers/Layers.cpp", aLine=219)
    at /home/bjacob/mozilla-central/xpcom/base/nsDebugImpl.cpp:345
#4  0x85746b90 in mozilla::layers::LayerManager::Mutated (this=0x48bcbe40, aLayer=0x48b0a940)
    at /home/bjacob/mozilla-central/gfx/layers/Layers.cpp:216
#5  0x84547a86 in mozilla::layers::Layer::Mutated (this=0x48b0a940)
    at ../../dist/include/Layers.h:879
#6  0x846daad0 in mozilla::layers::Layer::SetTileSourceRect (this=0x48b0a940, aRect=0x464fdfc8)
    at ../../dist/include/Layers.h:677
#7  0x846d9304 in mozilla::layout::BuildBackgroundPatternFor (aContainer=0x463b0480, 
    aShadowRoot=0x48204220, aMetrics=..., aConfig=..., aManager=0x48bcbe40, aFrame=0x48c28730, 
    aBuilder=0x464fe890) at /home/bjacob/mozilla-central/layout/ipc/RenderFrameParent.cpp:520
#8  0x846d9c4c in mozilla::layout::RenderFrameParent::BuildLayer (this=0x48c58600, 
    aBuilder=0x464fe890, aFrame=0x48c28730, aManager=0x48bcbe40, aVisibleRect=...)
    at /home/bjacob/mozilla-central/layout/ipc/RenderFrameParent.cpp:669
#9  0x846da350 in nsDisplayRemote::BuildLayer (this=0x47bddab8, aBuilder=0x464fe890, 
---Type <return> to continue, or q <return> to quit---
    aManager=0x48bcbe40) at /home/bjacob/mozilla-central/layout/ipc/RenderFrameParent.cpp:822
#10 0x845437d4 in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1333
#11 0x8454363c in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1294
#12 0x8454363c in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1294
#13 0x8454363c in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1294
#14 0x8454363c in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1294
#15 0x8454363c in mozilla::(anonymous namespace)::ContainerState::ProcessDisplayItems (
    this=0x464fe5d8, aList=..., aClip=...)
    at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1294
#16 0x84544864 in mozilla::FrameLayerBuilder::BuildContainerLayerFor (this=0x464fe890, 
    aBuilder=0x464fe890, aManager=0x48bcbe40, aContainerFrame=0x486777a8, aContainerItem=0x0, 
    aChildren=...) at /home/bjacob/mozilla-central/layout/base/FrameLayerBuilder.cpp:1636
#17 0x84588db4 in nsDisplayList::PaintForFrame (this=0x464fec3c, aBuilder=0x464fe890, aCtx=0x0, 
    aForFrame=0x486777a8, aFlags=5)
    at /home/bjacob/mozilla-central/layout/base/nsDisplayList.cpp:560
#18 0x84588b4c in nsDisplayList::PaintRoot (this=0x464fec3c, aBuilder=0x464fe890, aCtx=0x0, 
    aFlags=5) at /home/bjacob/mozilla-central/layout/base/nsDisplayList.cpp:504
#19 0x845b479e in nsLayoutUtils::PaintFrame (aRenderingContext=0x0, aFrame=0x486777a8, 
---Type <return> to continue, or q <return> to quit---
    aDirtyRegion=..., aBackstop=4294967295, aFlags=260)
    at /home/bjacob/mozilla-central/layout/base/nsLayoutUtils.cpp:1638
#20 0x845d84fa in PresShell::Paint (this=0x482157c0, aViewToPaint=0x4863c9e0, 
    aWidgetToPaint=0x48215650, aDirtyRegion=..., aIntDirtyRegion=..., aPaintDefaultBackground=0, 
    aWillSendDidPaint=0) at /home/bjacob/mozilla-central/layout/base/nsPresShell.cpp:6052
#21 0x84b45af6 in nsViewManager::RenderViews (this=0x4865f100, aView=0x4863c9e0, 
    aWidget=0x48215650, aRegion=..., aIntRegion=..., aPaintDefaultBackground=0, 
    aWillSendDidPaint=0) at /home/bjacob/mozilla-central/view/src/nsViewManager.cpp:449
#22 0x84b459ee in nsViewManager::Refresh (this=0x4865f100, aView=0x4863c9e0, aWidget=0x48215650, 
    aRegion=..., aUpdateFlags=1) at /home/bjacob/mozilla-central/view/src/nsViewManager.cpp:424
#23 0x84b46cc8 in nsViewManager::DispatchEvent (this=0x4865f100, aEvent=0x464fefd8, 
    aView=0x4863c9e0, aStatus=0x464fef90)
    at /home/bjacob/mozilla-central/view/src/nsViewManager.cpp:930
#24 0x84b41690 in HandleEvent (aEvent=0x464fefd8)
    at /home/bjacob/mozilla-central/view/src/nsView.cpp:161
#25 0x8540131a in nsWindow::DispatchEvent (this=0x48215650, aEvent=0x464fefd8)
    at /home/bjacob/mozilla-central/widget/src/android/nsWindow.cpp:633
#26 0x85401e1c in nsWindow::DrawTo (this=0x48215650, targetSurface=0x0)
    at /home/bjacob/mozilla-central/widget/src/android/nsWindow.cpp:925
#27 0x85401f82 in nsWindow::DrawTo (this=0x48214510, targetSurface=0x0)
    at /home/bjacob/mozilla-central/widget/src/android/nsWindow.cpp:953
#28 0x854022e6 in nsWindow::OnDraw (this=0x48214510, ae=0x46334800)
    at /home/bjacob/mozilla-central/widget/src/android/nsWindow.cpp:1027
#29 0x85401af4 in nsWindow::OnGlobalAndroidEvent (ae=0x46334800)
    at /home/bjacob/mozilla-central/widget/src/android/nsWindow.cpp:829
#30 0x853f90b4 in nsAppShell::ProcessNextNativeEvent (this=0x4638c8e0, mayWait=0)
    at /home/bjacob/mozilla-central/widget/src/android/nsAppShell.cpp:395
#31 0x8540997c in nsBaseAppShell::DoProcessNextNativeEvent (this=0x4638c8e0, mayWait=0)
---Type <return> to continue, or q <return> to quit---
    at /home/bjacob/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:171
#32 0x85409d2e in nsBaseAppShell::OnProcessNextEvent (this=0x4638c8e0, thr=0x46334080, mayWait=0, 
    recursionDepth=0) at /home/bjacob/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:312
#33 0x85482f6a in mozilla::dom::ContentParent::OnProcessNextEvent (this=0x48206c30, 
    thread=0x46334080, mayWait=0, recursionDepth=0)
    at /home/bjacob/mozilla-central/dom/ipc/ContentParent.cpp:934
#34 0x8562ee76 in nsThread::ProcessNextEvent (this=0x46334080, mayWait=0, result=0x464ff47c)
    at /home/bjacob/mozilla-central/xpcom/threads/nsThread.cpp:582
#35 0x855c3bde in NS_ProcessNextEvent_P (thread=0x46334080, mayWait=0) at nsThreadUtils.cpp:250
#36 0x854b9ea0 in mozilla::ipc::MessagePump::Run (this=0x463222b0, aDelegate=0x4631a0c0)
    at /home/bjacob/mozilla-central/ipc/glue/MessagePump.cpp:110
#37 0x856805d4 in MessageLoop::RunInternal (this=0x4631a0c0)
    at /home/bjacob/mozilla-central/ipc/chromium/src/base/message_loop.cc:219
#38 0x85680562 in MessageLoop::RunHandler (this=0x4631a0c0)
    at /home/bjacob/mozilla-central/ipc/chromium/src/base/message_loop.cc:202
#39 0x8568050a in MessageLoop::Run (this=0x4631a0c0)
    at /home/bjacob/mozilla-central/ipc/chromium/src/base/message_loop.cc:176
#40 0x85409a06 in nsBaseAppShell::Run (this=0x4638c8e0)
    at /home/bjacob/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:189
#41 0x851e3c14 in nsAppStartup::Run (this=0x47b9b430)
    at /home/bjacob/mozilla-central/toolkit/components/startup/nsAppStartup.cpp:218
#42 0x842dd94c in XRE_main (argc=3, argv=0x46313208, aAppData=0x4630f080)
    at /home/bjacob/mozilla-central/toolkit/xre/nsAppRunner.cpp:3754
#43 0x842ed250 in GeckoStart (data=0x4630c6f0)
    at /home/bjacob/mozilla-central/toolkit/xre/nsAndroidStartup.cpp:132
#44 0x842ed38c in Java_org_mozilla_gecko_GeckoAppShell_nativeRun (jenv=0xf4908, jc=0x40576c70, 
    jargs=0x405c9780) at /home/bjacob/mozilla-central/toolkit/xre/nsAndroidStartup.cpp:163
#45 0x8030693e in Java_org_mozilla_gecko_GeckoAppShell_nativeRun (jenv=0xf4908, jc=0x40576c70, 
---Type <return> to continue, or q <return> to quit---
    one=0x405c9780) at /home/bjacob/mozilla-central/other-licenses/android/APKOpen.cpp:234
#46 0xaca11e38 in dvmPlatformInvoke () from libdvm.so
#47 0xaca436e2 in dvmCallJNIMethod_general () from libdvm.so
#48 0xaca436e2 in dvmCallJNIMethod_general () from libdvm.so
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(Reporter)

Comment 1

7 years ago
Apparently this is a known not-implemented-yet bug with a patch from heeen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628566
You need to log in before you can comment on or make changes to this bug.