If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fennec autofills only my username, not my password, on Wordpress's login screen

NEW
Unassigned

Status

Fennec Graveyard
General
7 years ago
6 years ago

People

(Reporter: justdave, Unassigned)

Tracking

Trunk
ARM
Android

Details

The password autofill works fine on Bugzilla, for example, but on Wordpress, it fails to fill my password (only my username).  This is using a profile synced with my desktop, and the password autofill for this site works fine on my desktop.

Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110420 Firefox/6.0a1 Fennec/6.0a1
Is this on your own blog or Wordpress.com?
My own.

Comment 3

7 years ago
Tested against Nexus S on Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110424 Firefox/6.0a1 Fennec/6.0a1.   Used my own wordpress, and password was sync'd just fine against desktop.

can you try wiping your desktop password, then resaving it, re-syncing to fennec, and try again?
Hmm, I didn't clear anything at all and it works now.  I've updated Fennec several times since then, perhaps whatever was broken was fixed on another bug.
This issue is reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0a1)Gecko/20110524
Firefox/6.0a1 Fennec/6.0a1
Device: HTC Desire
OS: Android 2.2

I've browsed to http://www-archive.mozilla.org/quality/browser/front-end/testcases/wallet/login.html and I've remembered 3 different usernames and passwords. There it was the same result as here, but without using a synced profile.
TC https://litmus.mozilla.org/show_test.cgi?id=12193 fails due to this bug.
You need to log in before you can comment on or make changes to this bug.