Mozmill jsbridge/python error when running on rtl builds

RESOLVED WORKSFORME

Status

Testing Graveyard
Mozmill
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: ahal, Unassigned)

Tracking

Details

(Whiteboard: [mozmill-2.0+])

(Reporter)

Description

7 years ago
I was going to test my screenshot patch on rtl builds but it seems that mozmill can't even get passed the setupModule. Only tested on Linux.

I used the fx4 arabic build: ftp://ftp.mozilla.org/pub/firefox/releases/latest-4.0/linux-x86_64/ar/

STR:
Run any test with the above build (change it to your platform)

Output:
INFO | error: uncaptured python exception, closing channel <jsbridge.network.Bridge connected 127.0.0.1:24242 at 0x2114518> (<type 'exceptions.KeyError'>:'uuid' [/usr/lib/python2.6/asyncore.py|readwrite|103] [/usr/lib/python2.6/asyncore.py|handle_read_event|428] [/home/ahal/git/mozmill/jsbridge/jsbridge/network.py|handle_read|93] [/home/ahal/git/mozmill/jsbridge/jsbridge/network.py|process_read|253] [/home/ahal/git/mozmill/jsbridge/jsbridge/network.py|fire_callbacks|234])
INFO | 

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed


I don't know how difficult this will be. It's also likely that once we fix this there will be a ton of other problems that crop up.
Does that only happen for Mozmill 2.0? I assume so because my all locales update tests are working pretty well.
Whiteboard: [mozmill-2.0?]
This is not a problem on the hotfix-1.5 branch and should be a regression on master.
Keywords: regression, regressionwindow-wanted

Comment 3

7 years ago
we should probably take it.
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]

Comment 4

7 years ago
Tried this with Firefox 4 Arabic builds, latest master and I cannot reproduce this.  I think perhaps this may have been an issue with the test and it wasn't clear what was happening.  But, it's working now, every test I run works just fine.

--> WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.