Mozilla stops all new connections to X11/XFree86 4.0.1

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: s335984, Assigned: pavlov)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After having mozilla open for a while (time it takes changes, from almost instant to about 20 minutes or so), no other new xwindow program can connect to the x server.  This happens even after one exits mozilla, forcing an xwindow restart.  I've tried this with Mozilla 0.6, Netscape 6, and Mozilla 0.7 on XFree86 4.0.1 and 4.0.2, (gnome, kde or neither).  No other program i've ever run does that.  i don't have any idea of how this is even possible so if this is not a bug just send me an email telling me i'm a moron and, if possible, what i'm doing wrong and i'll go back to my hole.

Comment 1

18 years ago
Alejandro, could you please read the Bug Writing Guidelines at
<http://www.mozilla.org/quality/bug-writing-guidelines.html> to see the
kinds of information we need in a bug report. Please report back with more
information (like BuildID and steps to reproduce) after reading those
guidelines and consider using the Bugzilla Helper to report future
bugs.

The Helper can be found at <http://www.mozilla.org/quality/help/bug-form.html>
Thanks for your help in testing Mozilla.

------------------------------------------------------------------------------
With line breaks the above comment looks like this:

After having mozilla open for a while (time it takes changes, from almost
instant to about 20 minutes or so), no other new xwindow program can
connect to the x server.  This happens even after one exits mozilla,
forcing an xwindow restart.  I've tried this with Mozilla 0.6, Netscape 6,
and Mozilla 0.7 on XFree86 4.0.1 and 4.0.2, (gnome, kde or neither).  No
other program i've ever run does that.  i don't have any idea of how this
is even possible so if this is not a bug just send me an email telling me
i'm a moron and, if possible, what i'm doing wrong and i'll go back to my
hole.
Assignee: asa → vishy
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
Summary: Mozilla stops all new connections to the xfree server ?? → Mozilla stops all new connections to the X11 server

Comment 2

18 years ago
I might be able to shed a little light on this...

I'm not sure if I've seen this with Mozilla, but I've seen Netscape 4 on Linux
crash in such a way that it blocks the X Server to the point that you need to
hit Ctrl-Alt-Backspace to close X so you can restart it.  (No new X connections,
the window manager still thinks Netscape's running and won't destroy the
windows, etc.)  It seems to be related to something on the page being loaded,
since usually when I hit such a problem, it happens again if I try to follow the
same link after restarting X.  I haven't had it happen on any site that was
important, so I've never tried to narrow it down further than that.

This is on XFree86 3.something (the latest update provided by RedHat for RedHat
6.2; I'm not at that computer right now, so I can't check the exact version).

As I said, I don't recall whether I've seen this happen with Mozilla as well,
but it could be the same problem or something similar.
(Reporter)

Comment 3

18 years ago
ok, additional notes:  BuildID is 2001010517  (but it happened with previous builds too, can't remember the numbers).  Steps to reproduce are quite simple: run mozilla.  sometimes it takes a while (15-20 minutes or so) of using mozilla for the problem to appear, sometimes it's almost instant, but it happens every time, without failure.  Doing a bit of experimenting, loading freshmeat.net seems to do it.  (still what i find strangest is that the problem persists after one exits mozilla.  and no, mozilla isn't still running without a window, ps x doesn't show any mozilla or lookalike, and it seems to exit properly)
(Reporter)

Comment 4

18 years ago
a detail i forgot to mention is the error message i get from all other new programs trying to open a main window (programs that already had an open window can open more windows).  it's:
cannot open display: :0

Comment 5

18 years ago
Reporter are you using TrueType fonts? If so take a look at bug 63477 and see if
its similar to what your seeing. Report back either way.

Comment 6

18 years ago
Another possible dupe is 64001 what do you guys think? 
(Reporter)

Comment 7

18 years ago
true type fonts are on but the problem is not that it's crashing.  nothing is crashing, it's just that new xwindow using programs cannot start.  also, unlike 63477, this happened with 4.0.1 too.  i'll test it with tt fonts turned off.
with respect to 64001, there is no problem with memory swapping.  in fact, the computer keeps responding very nicely, even if i have something compiling on the side without much hard drive activity.  and it does not take 4 hours to get triggered, most of the time 3 minutes is about enough (running on 192 mb)

Comment 8

18 years ago
I am going to go ahead and mark this NEW. I am out of ideas on this one and
maybe someone with more experience can help figure it out.

Comment 9

18 years ago
Really Marking NEW...No Really I mean it...No dont kill me ahhhh :)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

18 years ago
Looks like a problem with XFree86, slightly resummarizing.
Over to pavlov for a look, I think he runs XFree86.
Pavlov, add comment and help find an owner?
Assignee: vishy → pavlov
Summary: Mozilla stops all new connections to the X11 server → Mozilla stops all new connections to X11/XFree86 4.0.1
(Assignee)

Comment 11

18 years ago
blizzard? any thoughts?  I don't currently have a machine with XFree86 on it...
No thoughts.  I use XFree exclusively and it works just fine and has for a very
long time.
(Assignee)

Comment 13

18 years ago
yeah, i've never had this problem with xfree86 4.0.x
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.