The table of contents on wiki.mozilla.org shouldn't push the contents down.

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: paul.biggar, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

8 years ago
On w.m.o, the table of contents appears above the actual contents, meaning we need to scroll to see the contents.

By contract, developer.m.o puts the table of contents at the side, and allows the page content to flow around it. This is a better layout, and allows people to immediately engage with the information they came here for.
Paul,

I'm not sure what the IT action here is? Users can edit the wiki and if mediawiki permits what you'd like, feel free to update it? I don't think this is a server side setting on mediawiki, so I'm pretty unsure as to what you'd like us to do here?
(Reporter)

Comment 2

8 years ago
Shyam, I filed here because the only wiki.bugzilla.org bug I could find was filed here. I'll see if I can figure out where this is really meant to go.

Updated

8 years ago
Assignee: server-ops → nobody
Component: Server Operations → wiki.mozilla.org
Product: mozilla.org → Websites
QA Contact: mrz → wiki-mozilla-org
(Reporter)

Updated

8 years ago
Blocks: 652719
Unlike developer.mozilla.org, wiki.mozilla.org still uses MediaWiki software, just like the Wikipedia and its sister projects. If you've been doing some Wikipedia editing, the MozillaWiki will instantly feel familiar, which IMHO is an advantage.

IIUC there are three possible ways to satisfy the reporter without disrupting existing people's customs (IMHO a clearly distinct TOC not embedded in the text makes it obvious that it _is_ the TOC and not some collection of "See also" links):

- Ask the MediaWiki developers to create a new skin with a "float:right" attribute to the TOC. This means reporting a new bug, of "enhancement" severity, at https://bugzilla.wikimedia.org/ and possibly closing this one as INVALID (not a Mozilla bug).
- Create a new custom skin, for use as a user's preference by logged-in users of the MozillaWiki, or for use by anyone by specifying it explicitly, in addition to the eleven already existing ones. For instance, to see the Bugzilla Update page, mentioned in the banner at the top of this page, in a look-and-feel more reminiscent of what the MozillaWiki used to show some years ago, browse to https://wiki.mozilla.org/index.php?title=BMO/40Upgrade&useskin=cavendish -- the last part, starting &useskin=, tells the MediaWiki software which skin you want.
- Change nothing in the site itself, and resolve this bug WONTFIX, declaring it to be the job of a browser customization. For example, add the following to the file userContent.css in the chrome subfolder of Firefox's or SeaMonkey's profile folder (and create the file if it doesn't exist):

/* Let text flow around the TOC of MozillaWiki pages */
@-moz-document domain(wiki.mozilla.org) {
 .toc
  { float: right    !important
  }
}

then restart the program. This should achieve the desired effect (I didn't try it). (If you don't know how to find your profile folder, see http://kb.mozillazine.org/Profile_folder_-_Firefox or http://kb.mozillazine.org/Profile_folder_-_SeaMonkey ). Alternately, it ought to be possible to obtain the same effect by means of a Firefox or SeaMonkey extension.
Severity: normal → enhancement
OS: Mac OS X → All
Hardware: x86 → All

Comment 4

7 years ago
perhaps Paul's OP report is primarily due to regress Bug 650955?  Table of Contents [toc] don't fit

xref Bug 551200 - Move table of contents into the sidebar in the wiki.mozilla.org theme
(Reporter)

Comment 5

7 years ago
Yes, its the same problem you raise in bug 650955 comment 3 ("In some cases even a small TOC causes no useful content to be displayed on the first screen"). It's pretty much the same as bug 551200.

I would DUP this to bug 551200, except that bug specifically asks for it to be moved to the sidebar, so I could see it being closed as WONTFIX or something.
close due to age / later events
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 7

4 years ago
(In reply to Alison Wheeler [:AlisonW] from comment #6)
> close due to age / later events

This isn't fixed - do you mean WONTFIX or INCOMPLETE instead?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Let's WONTFIX this. We're not addressing non-critical bugs on deprecated themes (of which GMO and Cavendish are). 

Some workarounds to know about:
* Page authors can add something like <div style="float:right;">__TOC__</div> if they want to move the TOC.
* Users can add float:right properties to their custom css to position the toc how they like. See https://www.mediawiki.org/wiki/User_style

We'll be sure to take into account the UX of the TOC as we work on the new theme.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 551200
You need to log in before you can comment on or make changes to this bug.