[enter] does not work in form(s)

VERIFIED DUPLICATE of bug 7081

Status

()

Core
HTML: Form Submission
P3
major
VERIFIED DUPLICATE of bug 7081
19 years ago
19 years ago

People

(Reporter: mikko.huhtala, Assigned: joki (gone))

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MAKINGTEST] Crysgem@hotmail.com, URL)

(Reporter)

Description

19 years ago
On pages where there is no separate 'submit' button next to
a form, pressing enter with cursor in the form does not work.
For instance, typing 'mozilla' in the 'find:' box at www.freshmeat.net
and pressing enter does nothing (enter starts the search in 4.06).
'Transferring data from freshmeat.net' appears but that's it.

Tag for the form is

<FORM METHOD="post" ACTION="http://core.freshmeat.net/search.php3">
<SMALL>find: <INPUT TYPE="text" SIZE="15" NAME="query"></SMALL></FORM>

I'm using precompiled M5 on an AMD K6 machine running RH 5.1.

Updated

19 years ago
Assignee: don → karnaze
Component: Apprunner → Form Submission

Updated

19 years ago
Assignee: karnaze → joki

Comment 1

19 years ago
This doesn't work on WinNT any more. It used to work. Tom, can you take a look.
nsFormControlFrame::HandleEvent checks for enter key events but they aren't
comming through any more.

Updated

19 years ago
QA Contact: leger → cpratt

Comment 2

19 years ago
Updating QA Contact

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Whiteboard: [MAKINGTEST] Crysgem@hotmail.com

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 7081 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.