Last Comment Bug 652011 - Switching between RSS folders, sometimes a message is auto selected and displayed
: Switching between RSS folders, sometimes a message is auto selected and displ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: unspecified
: x86_64 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 16:30 PDT by David
Modified: 2012-09-22 10:30 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David 2011-04-21 16:30:12 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

I've recently upgraded from Thunderbird 2.0.* to Thunderbird 3.1.9 and I am on Windows XP 64-bit version. I have one POP account and one RSS account (with about 70 feeds) setup in Thunderbird. I have it set up in "Classic View" with the Message Pane enabled. When I click on different folders in the POP account, I see the list of messages in the top-right pane, and the Message Pane is always blank until I select an e-mail to read. However, when I click on different RSS feeds, sometimes one of the messages in that feed is automatically selected and displayed in the Message Pane. I have tried setting mailnews.remember_selected_message to false, but this had no effect on the behavior I am seeing. This doesn't seem to be related to TB remembering a last selected message, it just randomly picks a message. New or old, read or unread doesn't seem to be a factor in which message is displayed either.

Reproducible: Sometimes

Steps to Reproduce:
1. Start Thunderbird, allow it to get new RSS messages
2. Select an RSS folder to see the list of messages
3. Sometimes a random message from the list is auto selected and displayed
Actual Results:  
Sometimes a random message from the list is auto selected and displayed

Expected Results:  
No message should be auto selected.

I only have one Extension/Add-On: Extra Folder Columns 1.1.3
I only have the Default Theme installed and in use
I have no plugins listed in the Add-Ons window
Comment 1 Ludovic Hirlimann [:Usul] 2011-04-27 03:59:04 PDT
Anything in Tools -> Error message when this happens ?

Does it happens when you don't run the extension ?
Comment 2 David 2011-04-27 16:28:26 PDT
I turned off the extension, and the problem still occasionally occurred.

I watched the Error Console while switching between folders, and the only messages that popped up were warnings about the content of the RSS messages that loaded.  No messages appeared in the error console because of switching between different RSS feeds.

Another piece of information, that may be unrelated, is that some of the feeds are set to load only the summary, and some of the feeds are set to load the original web page.  I basically never saw a warning when loading a message that was a summary only.  However, most of the messages that load the original web page would produce many, many warnings in the error console.  Also note, however, that random message selection occurred in both summary-type and full-web-page-type RSS feeds.  So, this does not seem to be a factor in the problem that I am seeing.

I am curious, does anyone know where in the code-base this material is?  For example, if I click on an RSS folder, what function calls are made?  I'd like to look through the source to see if I can see a problem, but there is a lot to go through and I'm not sure which part of the code is being called.  Thanks for your time.
Comment 3 Ludovic Hirlimann [:Usul] 2011-04-28 02:41:59 PDT
 > I am curious, does anyone know where in the code-base this material is?  For
> example, if I click on an RSS folder, what function calls are made?  I'd like
> to look through the source to see if I can see a problem, but there is a lot to
> go through and I'm not sure which part of the code is being called.  Thanks for
> your time.

David could you give a few details/hint on how things work ?
Comment 4 David 2011-04-28 05:27:00 PDT
> David could you give a few details/hint on how things work ?

I'm not sure I understand your question.  Are you asking me to describe how I normally use Thunderbird?  Or, are you asking me to describe how the code for Thunderbird works?
Comment 5 Ludovic Hirlimann [:Usul] 2011-04-28 05:44:23 PDT
I was talking to david bienvenu, I had not spotted that your name was david too :-)
Comment 6 David :Bienvenu 2011-04-28 07:00:33 PDT
mail/base/content/folderDisplay.js handles most of the selection stuff. mail/base/modules/dbViewWrapper.js sits on top of most of the message list handling.
Comment 7 alta88 2012-09-22 10:30:06 PDT
this is likely fixed in bug 596234 (Tb 18).  reopen if not.

Note You need to log in before you can comment on or make changes to this bug.