mail.trusteddomains behavior

RESOLVED DUPLICATE of bug 568976

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 568976
7 years ago
6 years ago

People

(Reporter: tim ramich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

Every piece of documentation I've seen about this feature has made it sound like it will allow remote content from the e-mail domain (from header.)  In reality it goes off the domain of the URL of the remote content.  This is an absolute pain.  I don't want to add e-mail addresses to an address book.  There are a bunch of domains (ebay, netflix, amazon, newegg, et al.) that have different actual senders even though the domain is the same.

Reproducible: Always

Steps to Reproduce:
1. about:config, add a single domain to mail.trusteddomains to test.
2. Restart
3. Open a message from added domain
Actual Results:  
None.

Expected Results:  
Example: I want it to behave in a way that if I type in "netflix.com" it will show images for both the receiving and shipping e-mail addresses from netflix.  This is explained everywhere (and from what I understand, intended) to use the From: header.

If I view the source of a message with multiple images and choose one domain to add, it will display images only from that domain.
According to http://mxr.mozilla.org/comm-central/search?find=%2F&string=mail.trusteddomains we don't use that pref at all anymore.


Mark shall I create a cleanup patch (or did I miss something) ?
Component: Security → Preferences
QA Contact: thunderbird → preferences
(In reply to comment #1)
> According to
> http://mxr.mozilla.org/comm-central/search?find=%2F&string=mail.trusteddomains
> we don't use that pref at all anymore.

On that search I see that its used in both nsMsgContentPolicy and nsSpamSettings.

I suspect that the pref is doing what was intended and this bug is probably a duplicate/dependency of some other bug on improving the remote content settings.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 568976
You need to log in before you can comment on or make changes to this bug.