Super User Marks Needed

VERIFIED FIXED in 1.0

Status

P1
blocker
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: lmesa, Assigned: lmesa)

Tracking

unspecified

Details

(Assignee)

Description

8 years ago
We need to create 100 super user marks to send to key influencers within Mozilla and other spheres of influence. 

These marks will be generated for the staged site, but need to be transferable to production. Will need to file an IT bug to export these contributor marks once we move to stage. 

Once those marks are generated in an IT bug, we need to place all the marks on the intranet wiki so we can keep track of them all. 

I will then be in charge of sending them out and managing/moderating these marks.

This is a blocker for release.
OS: Mac OS X → All
Hardware: x86 → All
I generated 5 translator invites and 5 contributor invites for QA (number 1 through 10!).

I generated another 100 contributor invites for your use (numbers 11 and to 110).

They all can be seen here:
https://markup.allizom.org/en/list_invites/

Log in as admin to see this. Feel free to copy out the keys and URLs from there.

I will give the QA invites to Matt via email, please DO NOT use those for real contributors.
In my testing, it seems like invite codes can be reused, and there's no way to tell which contributor code was used for what mark? :( Please keep that in mind when asking people to submit. People will probably need to tell you what mark they submitted (the URL or code, such as "8yBk"). Then you could collect those into a set of marks that we need to export and drop onto prod when deploying.

Comment 3

8 years ago
You can reuse invite codes to submit marks, but you CAN'T reuse them to submit contributor marks. If a user submits a mark using an invited code that has already been used, their mark will still be saved, but it will be treated as a regular submission. If it's not working like that, then this is a bug. Otherwise it's working as designed. 

I'm not convinced we do need to retain any connection between contributor marks and invite code. For exporting purposes, you just need to grab all marks from staging where their contributor columns are not null. Each mark from a contributor should have their name in the contributor column, so we shouldn't need them to indicate which marks they submitted.
(Assignee)

Updated

8 years ago
Assignee: nobody → lmesa
(Assignee)

Comment 4

8 years ago
We have all the key contributors we need to go. Resolving.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
It looks like the intent of this bug has been fulfilled, creating and capturing superuser marks. Per comment 4 I'll resolve this as VERIFIED. Please reopen or open a new bug if a nuance is missing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.