Closing tabs leaves an empty space on the right when tabbar is scrolled to the right

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: glandium, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

A few more specifics. This happens when there are a lot of open tabs and the tabbar is scrolled up to the last tab.
- when closing the last tab, all tabs are scrolled to the right
- when closing other tabs, tabs on the right of the closed tab are scrolled to the left, leaving an empty space on the right. This feels weird.

I believe the latter should have the same kind of behaviour as the former.
So, it seems that the code added to address the second issue I pointed out in https://bugzilla.mozilla.org/show_bug.cgi?id=465086#c194 does not work in the case where the tabbar has been scrolled to the right.
Keywords: regression
(In reply to comment #1)
> A few more specifics. This happens when there are a lot of open tabs and the
> tabbar is scrolled up to the last tab.
> - when closing the last tab, all tabs are scrolled to the right
> - when closing other tabs, tabs on the right of the closed tab are scrolled to
> the left, leaving an empty space on the right. This feels weird.
> 
> I believe the latter should have the same kind of behaviour as the former.

This is intended behavior. Making it easy to close the next tab is more important than seeing all of your tabs as once, which wouldn't be able to anyways since you already opened enough tabs to be in overflow mode.

(In reply to comment #3)
> So, it seems that the code added to address the second issue I pointed out in
> https://bugzilla.mozilla.org/show_bug.cgi?id=465086#c194 does not work in the
> case where the tabbar has been scrolled to the right.

The reason for moving the tab on the right to fill the space is that the tab on the right is very likely the tab that will be selected upon closing a tab. It is more helpful to be able to see the tab before you decide to close it by clicking.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Frank, would you mind to elaborate?
(In reply to comment #5)
> Frank, would you mind to elaborate?

Forget this, I hadn't seen comment 4.
Kind of makes sense, though confusing at first.
There's however an unexpected side effect: when you close tabs and scroll the tabbar on the left, and then on the right again, you can continue scrolling after the last tab, recreating the empty space you created by closing the tabs.
You need to log in before you can comment on or make changes to this bug.