Should fallback to search in case of DNS lookup error

RESOLVED DUPLICATE of bug 523132

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 523132
8 years ago
7 years ago

People

(Reporter: cmr.pent, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20110327 Firefox/4.0 Iceweasel/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20110327 Firefox/4.0 Iceweasel/4.0

Long ago, browsers only allowed users to enter valid page address in address textbox. Firefox was one of the first browsers to introduce the revolutionary paradigm of "Location bar": now users are not required to know/remember the exact page address, they can enter search phrase and get to the desired site! Google and Firefox really changed the way people use the Web nowadays.

However, currently one cannot reliably use search phrase containing "." (dot). For example, if I enter ".net", I get rather unhelpful message:

Firefox cannot find server www..net.

However, if I use Google search, I immediately get what I expect in the first link: a page describing Microsoft .NET (http://ru.wikipedia.org/wiki/.NET_Framework).

I propose that in such a case Firefox falls back to search engine method instead of reporting error. It should happen only once to prevent infinite loop in case of offline site.

I believe search queries containing "." are rather common for some categories of people, i.e. for programmers as "." is a special symbol in many programming languages.


Reproducible: Always

Steps to Reproduce:
1. Enter ".net" in Location bar
2. Press "Enter"


Actual Results:  
Unhelpful error message

Firefox cannot find server www..net.


Expected Results:  
Load page http://ru.wikipedia.org/wiki/.NET_Framework

-or-

show search results on ".net"

Comment 1

8 years ago
Behavior reproduced with a new clean profile:
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110424 Firefox/6.0a1
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523132
You need to log in before you can comment on or make changes to this bug.