Tab-resize occurs immediately after leaving tab-bar when a persona or theme used.

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: vadi.iletisim, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110423 Firefox/6.0a1
Build Identifier: 

In bug 465086, it is implemented that tab resize should not occur until cursor leaves tab toolbar.

When using default theme, tab resize doesn't happen until pointer leaves tab-bar and url-bar both, like Chrome.

But when a theme or a persona is used. tab resize occurs immediately adter pointer leaves tab-bar. Tab resize occurs when pointer leaves tab-bar and goes address bar (url-bar). 

Reproduced in Aurora and Nightly in Windows 7.

Reproducible: Always

Steps to Reproduce:
1. Wear a persona or install a theme on Firefox.

2. Open a couple of tabs in browser. 

3. Close 2-3 tabs from the middle and make cursor go to the address bar.


Actual Results:  
Tabs widths are resized immediately.

Expected Results:  
Tabs should not be resized since pointer didnt leave the whole toolbar.
(Reporter)

Updated

8 years ago
Blocks: 465086

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
Not reproduced on Nightly 6.0a1 with a non-default theme. Maybe this is a duplicate of bug 649441.
Reporter, do you have any other add-ons installed? Do you have the tabbar on top? Can you reproduce in a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Reporter, do you have any other add-ons installed? Do you have the tabbar on
> top? Can you reproduce in a fresh profile
> (http://support.mozilla.com/en-US/kb/Managing+profiles)?

i reproduced with fresh profile.

in comments of bug 465086 daniel.nr01@yahoo.se also reproduced the bug.

Comment 4

8 years ago
We want to change the behavior so that it always resizes immediately when leaving the tab bar, so WONTFIX'ing this.

See bug 652735.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.