All users were logged out of Bugzilla on October 13th, 2018

Voting for bugs where the product allows only one vote per bug but that isn't clear in the voting form or help

RESOLVED FIXED in Bugzilla 4.2

Status

()

--
minor
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: chrishold, Assigned: dkl)

Tracking

Bugzilla 4.2
Bug Flags:
approval +

Details

(Whiteboard: [bmo4.0-resolved], URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Bugzilla v4.0 (but bug is about the implementation for Thunderbird project,  not against bugzilla)

The Thunderbird team have apparently decided that one user can only give one vote per bug which seems to be daft given an allocation of 1000 votes.  My wish is for that to be changed to allow more flexible voting.  However, the bug report is that your voting form has been changed to only give a checkbox but it still has text suggesting you should be able to input a number of votes and your help page about voting is quite explicit that you can allocate any number of your 1k votes per bug.  This wastes user time, makes us less likely to report bugs, and needs fixing!  Thanks.

Reproducible: Always

Steps to Reproduce:
1.  Try to vote for a bug!
2.
3.

Actual Results:  
Try to vote for a bug, you get the confusing text and the checkbox.  Click on the voting help, you'll see the line that says we can allocate any points up to our remaining total against any bug: needs changing.

Expected Results:  
Should be clear it's one vote per bug and voting form and help should reflect that (or change your policy).

The whole bugzilla system is desperately unfriendly to non-computing, non-programming end users.
(Reporter)

Updated

8 years ago
Blocks: 652325

Updated

8 years ago
OS: Windows XP → All
Hardware: x86 → All
Keywords: user-doc-needed
fwiw all the main Mozilla products only allow one vote per bug.
Summary: Voting for Thunderbird bugs allows only one vote per bug but that isn't clear in the voting form or help → Voting for bugs where the product allows only one vote per bug but that isn't clear in the voting form or help

Comment 2

8 years ago
(In reply to comment #0)
> Actual Results:  
> Try to vote for a bug, you get the confusing text and the checkbox.  Click on
> the voting help, you'll see the line that says we can allocate any points up to
> our remaining total against any bug: needs changing.

That's not true. That's not what's written at all. What's written is "Depending on how the administrator has configured the relevant product, you may be able to vote for the same bug more than once." And as Mark said in comment 1, all products allow only one vote per bug in bugzilla.mozilla.org. The doc is clear to me. This is IMO WFM.
(Assignee)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

8 years ago
Resolution: WONTFIX → WORKSFORME
Well the part "Indicate how many votes you want to give this bug" could read "Vote for the bug by setting its checkmark. Or, if the administrator has allowed multiple votes per bug, indicate how many votes you want to give this bug."

This may be redundant, but if you're like me and have kind of a tl;dr mindset, you might have missed the clear part above.
(Reporter)

Comment 4

8 years ago
I agree with Marc and hope this request to improve usability of TB bugzilla isn't just killed as "RESOLVED: WORKSFORME"!

I think that how to interpret anything written is always easier if you start out knowing what it's supposed to do so anyone who knows that no Mozilla product allows more than one vote per bug in bugzilla will see how the voting pages say that.  Those of us who assume that being given 1000 votes is highly unlikely to mean that we should find the top 1000 bugs that seem important to us, will not necessarily read things the same way.

This could spin off three new requests: 
1) that "one vote per bug" is very restrictive
2) that having 1000 votes with one per bug is overload and confusing
3) that there should be a bug against bugzilla as an improvement suggestion asking the wording of the voting page and voting help page to be improved further and perhaps to change depending on how the operator of the particular bugzilla instance has configured it.

However, I don't have the energy for those but still feel the wording here can be improved.   I'll try to attach two screenshots to help with my comments.

29-04-2011 10-02-01_bugzilla_voting1.png is a screenshot of my voting panel with comments.  I hope it is clear.

29-04-2011 10-06-11_bugzilla_voting2.png highlights the text in the help page.  I can see that it's very clear to Marc but to me things are not that clear:
"Each product allows users to have a certain number of votes. (Some products may not allow any, which means you can't vote on things in those products at all.)"  To me, at first reading, that said I had a number of votes and I skipped the next bit as it clearly didn't apply.
"With your vote, you indicate which bugs you think are the most important"
Well, I have very limited power to indicate which I think are MOST important with one vote per bug, all I can do is separate some I do think are important to me from the others.  I read this as confirming that I could use my votes to indicate which votes I thought were more important than others: literally to rate them.
"Depending on how the administrator has configured the relevant product, you may be able to vote for the same bug more than once" That's bad grammar: I took it to me that some configurations allow you to change your vote (the literal meaning of "to vote more than once" that you can only vote once ever is clearly wrong as you'd only ever vote for one bug were that true), i.e. that I could vote twice or more times for this bug.  I did wonder if that was how I notched up votes for a bug: by voting repeatedly for it until my votes felt right or I ran out so I tried that but no vote count appeared alongside the checkbox and my votes stayed one per bug (I had only used two ever by then: I'm not a regular here!)
"When weighted voting is allowed and a limited number of votes are available to you, you will have to decide whether you want to distribute your votes among a large number of bugs indicating your minimal interest or focus on a few bugs indicating your strong support for them."
I was sure that was what you would have allowed and the alternative in the paragraph above seemed only to be that voting could be switched off altogether so that seemed to confirm that I had the option to vote more for a bug that is really a pain for me.

Then the killer, under "To vote for a bug:"
"Indicate how many votes you want to give this bug. This page also displays how many votes you've given to other bugs, so you may rebalance your votes as necessary."
Nothing there at all about that being "if your instance of bugzilla allows this ..."

OK, my bug is probably really against the 1 vote per bug and the 1000 votes and separately against the wording of the bugzilla voting pages.  Surely they should say:
"For this product (product_name) the system team allow you [max_votes] and you [can only give one vote per bug | can use as many of your votes as you like per bug up to your total number of votes [max_votes]" or...
"The system team responsible for this product (product_name) have opted not to allow voting.  Remember, fixes help products improve more than votes!"
(Reporter)

Comment 5

8 years ago
Created attachment 529077 [details]
Annotated screen grab, goes with my post of 29.iv.11
(Reporter)

Comment 6

8 years ago
Created attachment 529078 [details]
2nd screen grab, goes with my post of 29.iv.11
(Assignee)

Updated

8 years ago
Component: Bugzilla: Other b.m.o Issues → User Interface
Product: mozilla.org → bugzilla.mozilla.org
QA Contact: general → ui
Version: other → Current
Don't understand dkl's switch from WONTFIX to WORKSFORME. Doesn't WORKFORME as the help text is unclear and does not describe the predominant 1-vote-per-bug setting used on BMO. I'm not worked up about it and don't care if you WONTFIX it (we probably have logs that show no one reads that page anyway) but a WORKSFORME seems to indicate a misunderstanding of what Chris is reporting. Chris is partly to blame for confusing the issue by leading with two sentences of complaint before getting to the issue of the bug.

> [Mozilla] have apparently decided that one user can only give one vote per
> bug which seems to be daft given an allocation of 1000 votes.  My wish is
> for that to be changed to allow more flexible voting.

You misunderstand the point of "1000 votes" which is essentially "unlimited" (the Core product allows 10,000 votes). Knowing that 100 separate people are interested in bug X is useful feedback; having one irate guy read a blog and dump 1000 votes on a single bug doesn't tell us much and would bury the more important fact that 100 people were interested in the other one. If someone goes and spends all 1000 votes then that just dilutes the meaning of a vote.

We also use the number of CC's to judge interest, pretty interchangeably with "votes". Since bugzilla allows you to specify different levels of email you get for bugs you're CC'd to and bugs you've voted for this lets heavily involved developers use one setting to get detailed mail about every/most changes while using the other for bugs where they only care about major changes like when it's resolved.

It's certainly not an "election" where the votes are tallied and the winner gets fixed, it's just an expression of interest which has to be balanced with other factors. Discussion of how Mozilla ought to handle bugs and voting comes up regularly on the newsgroups and I urge you to discuss it there (and in fact, to look up previous discussions in Google Groups first so we don't have to rehash all the same arguments).
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
(Assignee)

Comment 8

8 years ago
Changing to upstream as BMO is not using any custom text for the voting pages so this is not a local change. Also this is not a regression as it was worded the same way for 3.6.
Assignee: nobody → ui
No longer blocks: 652325
Component: User Interface → User Interface
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: ui → default-qa
Version: Current → 4.0
(Assignee)

Comment 9

8 years ago
Created attachment 531473 [details] [diff] [review]
Patch to update working next to voting checkbox (v1)

Here is a simple patch that changes the wording next to the voting checkbox or text field depending on how many votes are allowed per user for a bug. If the user is only allowed on vote it will say instead "Vote For This Bug ->". If the are allowed more than one it will say "Enter Votes Here ->". This should alleviate some of the confusion. 

dkl
Attachment #531473 - Flags: review?(LpSolit)

Comment 10

8 years ago
Comment on attachment 531473 [details] [diff] [review]
Patch to update working next to voting checkbox (v1)

>+                [% IF onevoteproduct %]

onevoteproduct is a global variable, which is true if at least one product allows only one vote. That's not what we want here. You probably want product.onevoteonly.
Attachment #531473 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 11

8 years ago
Created attachment 536216 [details] [diff] [review]
Patch to update wording next to voting checkbox (v2)

Thanks LpSolit. Here is updated patch.

dkl
Assignee: ui → dkl
Attachment #531473 - Attachment is obsolete: true
Attachment #536216 - Flags: review?(LpSolit)

Updated

7 years ago
Severity: normal → minor
Status: REOPENED → ASSIGNED
Keywords: user-doc-needed

Comment 12

7 years ago
Comment on attachment 536216 [details] [diff] [review]
Patch to update wording next to voting checkbox (v2)

r=LpSolit
Attachment #536216 - Flags: review?(LpSolit) → review+

Updated

7 years ago
Flags: approval+
Target Milestone: --- → Bugzilla 4.2
(Assignee)

Comment 13

7 years ago
Thanks.

trunk:
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified extensions/Voting/template/en/default/pages/voting/user.html.tmpl
Committed revision 7844

dkl
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [bmo4.0-resolved]
You need to log in before you can comment on or make changes to this bug.