Firefox4 do not show video from IP camera (firefox 3.6 was ok)

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: escdagent, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

follow the link : http://218.32.76.61/
no video is displayed with firefox 4,
all the rest of the browsers are ok.

If im not wrong, hunt and many other IP cameras
use active x for video.

Reproducible: Always

Steps to Reproduce:
1. follow the link to IP camera : http://218.32.76.61/
2. no video is displayed
3.

Actual Results:  
no video is displayed

Expected Results:  
video should be there :D

no

Comment 1

7 years ago
Spoofing the useragent works - looks like bad UA sniffing.

function CheckBrowser()
{
	var userAgent = navigator.userAgent; //Get userAgent
	if(userAgent.indexOf("Windows") > -1)
	{
		var isOpera = userAgent.indexOf("Opera") > -1;
		if (isOpera){return "Opera"}; //Is Opera
		if (userAgent.indexOf("Firefox") > -1){return "FF";} //Is Firefox
		if (userAgent.indexOf("Chrome") > -1){return "Chrome";} //Is Chrome
		if (userAgent.indexOf("Safari") > -1)//Is Safari
		{
			if (userAgent.indexOf("Mobile") > -1) {return "IPhone";} //Is IPhone
			return "Safari";
		} 
		if (userAgent.indexOf("compatible") > -1 && userAgent.indexOf("MSIE") > -1 && !isOpera){return "IE";} ; //Is IE
	}
	else
	{
		if (userAgent.indexOf("Android") > -1)//Is Safari
		{
			if (userAgent.indexOf("Mobile") > -1) {return "Android";} //Is IPhone
			return "MJPEG";
		}
		else if (userAgent.indexOf("Safari") > -1)//Is Safari
		{
			if (userAgent.indexOf("Mobile") > -1) {return "IPhone";} //Is IPhone
			return "MJPEG";
		}
		else
		{
			return "MJPEG";
		} 	
	}
} //myBrowser() end
Assignee: nobody → english-us
Severity: major → normal
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
(Reporter)

Comment 2

7 years ago
Well, i have set up a plugin called "User Agent switcher 0.73"
when i set my ID to "google bot" it works :) but this is somehow
a workaround, and firefox at its default setup is not working...
(Reporter)

Comment 3

7 years ago
The problem is that plugin do not save its last settings, and each time I restart
Firefox, i will need to seto new browser ID again.
(Reporter)

Comment 4

7 years ago
At the recent firefox update, 4.0.1 the issue was not fixed.
I see the status is "UNCO" which means unconfirmed, does this
means the IP cameraswork for somebody with default setup?

Comment 5

7 years ago
The issue is with the camera manufacturer - feel free to contact them and reference this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
so Eugene: who made this camera and do you think this is still an issue? If not, I'll happily close it for you ;-)
Flags: needinfo?(escdagent)
(Reporter)

Comment 7

5 years ago
You may close it, its right in time I guess.
Flags: needinfo?(escdagent)
Thank you for confirming that :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.