Closed Bug 652466 Opened 9 years ago Closed 9 years ago

Flash (SWF) not cached

Categories

(SeaMonkey :: General, defect)

x86
Windows Server 2003
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 647391

People

(Reporter: vshalimhr, Unassigned)

References

()

Details

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.2; rv:2.0pre) Gecko/20110408 SeaMonkey/2.1b3
Build Identifier: Mozilla/5.0 (Windows NT 5.2; rv:2.0pre) Gecko/20110408 SeaMonkey/2.1b3

Flash files are not cached in disk cache if their size is greater than around 5 MB. I don't know the exact size, 5 MB is my guess based on a few tests.

Reproducible: Always

Steps to Reproduce:
1. Open an SWF file bigger than 5 MB, e.g. http://cache.armorgames.com/files/games/bela-kovacs-and-the--11171.swf
2. Open it again (in another window, or by clicking the "Go" button in the location bar, or just reload the page).


Actual Results:  
The browser doesn't cache the file. The file is not even saved to disk (neither in the %TEMP% directory, nor in browser cache directory) - the free space is not decreasing while the file is downloaded (nor after the file has been fully downloaded) and not increasing after closing the browser.


Expected Results:  
The file should be cached in the disk cache.


Reproducible in both normal and safe modes.
HTTP request and response headers for the case when a file is not cached.
HTTP request and response headers for the case when a file is cached.
Now I understand why changing "media.cache" from 512000 to 2048000 in about:config didn't help - the limit is hardcoded. Great job.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 647391
(In reply to comment #7)
> "media.cache"

I mean "media.cache_size".
You need to log in before you can comment on or make changes to this bug.