Closed Bug 652505 Opened 9 years ago Closed 9 years ago

XML-RPC API for adding comments is broken on b.m.o.

Categories

(bugzilla.mozilla.org :: General, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: gerv, Unassigned)

References

Details

Attachments

(1 file)

See the attached test file. The code works fine requesting a bug from my local install, but not from b.m.o. 

The error string is:
"Application failed during request deserialization: 
no element found at line 1, column 0, byte -1 at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/Parser.pm line 187

This is also the error BzAPI is getting back when it attempts to add comments (see bug 652452).

Gerv
This breaks bzexport, which is unfortunate:
http://hg.mozilla.org/users/tmielczarek_mozilla.com/bzexport/

(Gerv: you didn't attach anything with your comment, AFAICT.)
Ted: thanks - just attached the script.

It looks like it's this:
https://rt.cpan.org/Public/Bug/Display.html?id=58538

Can someone please hack bmo's SOAP::Lite?

Gerv
Attachment #528126 - Attachment mime type: application/x-perl → text/plain
(Sidenote: is our new MIME type-guessing code being a big aggressive? Ted had to change the MIME type of the file I uploaded from application/x-perl to text/plain. I think we probably want a bunch of types like that to be guessed as text/plain...)

Gerv
justdave, what version of SOAP::Lite is installed on BMO? I have SOAP::Lite 0.711 on my local system and comment attaching works for me. Are you using the rpm that comes with RHEL?

dkl
We're using 0.712 on b.m.o because:

[06:49:46] Checking for            SOAP-Lite (v0.712)    ok: found v0.712 

checksetup.pl said we needed 0.712.

We used to be version-locked on 0.710 because 0.711 had a bug I don't remember the details of that was breaking stuff.  Supposedly that bug got fixed in 0.712 and I assumed that was the reason Bugzilla was requiring it.
This is a blocker issue.  It breaks a bunch of tools that our developers rely on, including but not limited to orange tracking facilities.
Severity: critical → blocker
I have a patched copy of perl-SOAP-Lite built, working on deploying it now.
Severity: blocker → critical
(In reply to comment #8)
> I have a patched copy of perl-SOAP-Lite built, working on deploying it now.

Deployed finally.  Test away and see if that fixed it.
This is a test comment - please disregard
(In reply to comment #10)
> This is a test comment - please disregard

This worked using Bug.add_comment. Please reopen this if the problem still persists. Otherwise mark as VERIFIED.

dkl
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
XML-RPC Bug.get now works using my test script.

Gerv
Duplicate of this bug: 652454
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.