Last Comment Bug 652506 - Remove WinCE code from xpcom
: Remove WinCE code from xpcom
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720 653319
  Show dependency treegraph
 
Reported: 2011-04-25 01:45 PDT by Ed Morley [:emorley]
Modified: 2011-05-02 17:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from xpcom (72.35 KB, patch)
2011-04-25 07:28 PDT, Ed Morley [:emorley]
benjamin: review+
Details | Diff | Splinter Review
Remove WinCE code from xpcom (72.36 KB, patch)
2011-05-01 08:33 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-04-25 01:45:23 PDT
WinCE code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the xpcom/* parts of the removal.

http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/xpcom/
Comment 1 Ed Morley [:emorley] 2011-04-25 07:28:21 PDT
Created attachment 528092 [details] [diff] [review]
Remove WinCE code from xpcom


Also Hg rms the following due to now no longer being used:

xpcom/reflect/xptcall/src/md/win32/xptcinvoke_asm_ce.asm
http://mxr.mozilla.org/mozilla-central/search?string=xptcinvoke_asm_ce.asm

xpcom/reflect/xptcall/src/md/win32/xptcinvokece.cpp
http://mxr.mozilla.org/mozilla-central/search?string=xptcinvokece.cpp

xpcom/reflect/xptcall/src/md/win32/xptcstubs_asm_ce.asm
http://mxr.mozilla.org/mozilla-central/search?string=xptcstubs_asm_ce.asm

xpcom/reflect/xptcall/src/md/win32/xptcstubsce.cpp
http://mxr.mozilla.org/mozilla-central/search?string=xptcstubsce.cpp

For follow up in another bug (since outside xpcom and I also need to find out if this wants to be kept for future use):
-> After this patch, build/mobile/devicemanager-utils.py is now no longer used (http://mxr.mozilla.org/mozilla-central/search?string=devicemanager-utils.py), so can likely be removed.
Comment 2 Ed Morley [:emorley] 2011-04-25 08:19:02 PDT
Comment on attachment 528092 [details] [diff] [review]
Remove WinCE code from xpcom

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=6847256b7306

Thanks :-)
Comment 3 Ed Morley [:emorley] 2011-05-01 08:33:42 PDT
Created attachment 529355 [details] [diff] [review]
Remove WinCE code from xpcom

Only change is updated commit message to include r=bsmedberg.

Carrying forwards r+.
Comment 4 Dão Gottwald [:dao] 2011-05-01 12:02:43 PDT
http://hg.mozilla.org/mozilla-central/rev/1e7f4ce5636f
Comment 5 Ed Morley [:emorley] 2011-05-02 17:23:49 PDT
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/xpcom/
...returns 0 results.

-> Verified.

Note You need to log in before you can comment on or make changes to this bug.