Requesting trunk access to mozilla.com

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: tarend, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
Based on https://bugzilla.mozilla.org/show_bug.cgi?id=651985#c7
Background: I need to publish Fennec release notes frequently. Currently, Stuart seems to be the only one who has access. 
Thank you
Assignee: nobody → mozillamarcia.knous
Component: www.mozilla.com → Repository Account Requests
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → repo-acct-req
Version: unspecified → other
You'll need to submit a committer's agreement to Erica, per http://www.mozilla.org/hacking/notification/ , and attach a public key here for SSH+SVN access.
No activity on this since 4/25 - have you given the form to Erica yet?
(Reporter)

Comment 3

7 years ago
Yes, I gave Erica the form today. Thanks!
Erica: Can you kindly confirm receipt of the form? thanks.

Comment 5

7 years ago
I have received Thomas' Committer's Agreement.
http://www.mozilla.org/hacking/commit-access-policy/ suggests that John Slater may need to vouch before you can have access to that area. Adding jslater to the bug.

Comment 7

7 years ago
A solid a=jslater from me. Thanks!
Over to server-ops for SVN access to @mozilla-com-trunk.
Assignee: mozillamarcia.knous → server-ops

Updated

7 years ago
Assignee: server-ops → desktop-support
SVN bits have been enabled.
Assignee: desktop-support → hlangi
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

7 years ago
Thanks. Just for reference: I requested update of my SSH public key in Bug 661321

Comment 11

7 years ago
Can you tell us what is the error message you are getting?
(Reporter)

Comment 12

7 years ago
svn checkout svn+ssh://svn.mozilla.org/projects/mozilla.com/trunk/en-US/mobile

Error message:
Permission denied (publickey,gssapi-with-mic)
svn: Network connection closed unexpectedly

Chatted with Henry who found that I have two keys - he is deleting the old one, but it is unclear if that may have an effect on the new key at all.
(Reporter)

Comment 13

7 years ago
Still no luck with svn access. Would you have any idea what I can try to resolve this? Thank you!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 14

7 years ago
Sorry to nag. Still the same SSH issue. Help?!
Assignee: hlangi → desktop-support
(Reporter)

Comment 15

7 years ago
I still can't access trunk. Could somebody help me check my laptop configuration to resolve this issue? Thank you!
Hey Thomas,

Ping on IRC when you get the chance tomorrow so I come by and check your configs.
(Reporter)

Comment 17

7 years ago
This is getting urgent now. Could you please help me get my MacBook set up in a way that I can update docs on Trunk. Thank you!!
Can you try adding your full username like:

svn+ssh://'tarend@mozilla.com'@svn.mozilla.org/projects/mozilla.com/trunk/en-US/mobile

If that works, try creating a file .ssh/config with the following two lines in it:

Host svn.mozilla.org
User tarend@mozilla.com
Created .ssh/config file and did an 'svn co' to access files.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.