Closed Bug 652631 Opened 10 years ago Closed 3 years ago

Sync do not track (DNT) pref across applications

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 631300

People

(Reporter: geekboy, Unassigned)

References

Details

(Keywords: privacy, Whiteboard: [sync:prefs])

Bug 631300 fixed syncing the DNT pref across installs of an application (Firefox to Firefox), but we should also sync across applications (e.g., Firefox to Fennec).   The feature should work anywhere necko is used, and your pref should come along for the ride.
Is there any way to get DNT pref sync'd across applications per Sid's comment above? This would strengthen the Sync/DNT story for Firefox 5 and beyond. Please let me know ASAP.
This would IMHO constitute what we now call a "feature" (with a priority, feature page, and all that) because we'd need to make the prefs sync engine aware of particular preferences that would be ok to be synced across particular apps. I'm certain this won't constitute a bugfix as far as the definition for mozilla-aurora approval is concerned, so Firefox 5 is pretty much out of the question. If the decision is made to make this a P1 feature, we can allocate the resources for it and catch whichever train we manage to make (maybe Firefox 6, but that's already getting pretty close.)
With the new press attention and pick-up that DNT is getting, media have been asking if we will implement this. It might be a good thing to assign it a priority.
Depends on: 621198
We still believe this is worth doing, but we need blessing/buyin from product, or a decision to put it on the 2012 roadmap.
Assignee: nobody → mconnor
We've talked about this, and decided that we should implement this in Q2.
Assignee: mconnor → nobody
Component: General → Firefox Sync: Backend
QA Contact: general → sync-backend
Asa verbally expressed concerns about this. To summarize, we've gone out of our way to ensure that this feature is opt-in. There are some people who may only want DNT on some devices. In short, we should probably take this to a public list, etc before implementing this.
Thanks for adding me, gps. 

I'm not saying we shouldn't, just that we should make sure this is the right thing to do. I'd defer to Alex on this and I assume we'll be OK to sync it -- just want to make sure.
I spoke with Syd and we're in agreement that making this change is a good thing.
OS: Linux → All
Hardware: x86 → All
Blocks: 745408
Whiteboard: [sync:prefs]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631300
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.