[Rapid Release] Implement redesign mobile/download page to reflect Beta channel and beyond

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: clooney, Assigned: christian)

Tracking

Firefox 4
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
-By Beta (5/17) - We'll want to include a link/button to Beta build in Android Market.
-We'll also want to phase out N900 (and user can find that in Firefox.com/m CTA).
-We want to make sure this page is similar and localized in the languages we offer in Firefox mobile.
(Reporter)

Updated

7 years ago
Priority: -- → P1

Comment 1

7 years ago
Thanks Caitlin. Can you give some more specific details around what it means to phase out the N900 here? Right now the page design is built around having those two options, so depending on those details I'll quite possibly ask you to file a design bug for this page as well.

Be sure to work directly with Pascal on l10n efforts and timing.
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → 2.4

Comment 2

7 years ago
hi john, had a chat with caitlin earlier, so we either want to take the nokia 900 completely.. or replace that with the beta download (orange download button) that will be available on 5/17. should i file a design bug for that? or can this be a website update bug? 

In addition, i've also scheduled a meeting tomorrow to review pages that needs to be updated for mobile beta release. 

I can also open a L10n bug for localization request. 

thanks!

Updated

7 years ago
Blocks: 652734

Comment 3

7 years ago
Please do file a design bug and make this one dependent on that one. We can figure out the details when we meet today.

Thanks!

Updated

7 years ago
Depends on: 652811

Comment 4

7 years ago
(In reply to comment #3)
> Please do file a design bug and make this one dependent on that one. We can
> figure out the details when we meet today.
> 
> Thanks!

Done: bug 652811

Comment 5

7 years ago
Steven - heads up this is coming your way once the design is done in bug 652811. Thanks!
Assignee: nobody → clooney
Summary: Redesign mobile/download page to reflect Beta channel and beyond → Implement redesign mobile/download page to reflect Beta channel and beyond

Comment 6

7 years ago
hi lauraf, 

Here is the final design for this page: 

http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/rapid_release/mobile_downloads_v4.png

Live Date: May 17th.

PLease let me know if you need any additional info.

thanks!

Updated

7 years ago
Assignee: clooney → steven

Comment 7

7 years ago
Looks good. 

Steven - feel free to have at it. Thanks!
Target Milestone: 2.4 → 2.5
Steven - if you need the PSD, it is available at:

http://people.mozilla.com/~jgrlicky/drop/mozcom/mobile_mockups/rapid_release/mobile_downloads_v4.psd

Thanks!

Updated

7 years ago
Summary: Implement redesign mobile/download page to reflect Beta channel and beyond → [Rapid Release] Implement redesign mobile/download page to reflect Beta channel and beyond

Comment 9

7 years ago
hi steven,

are we good to go here?
Done in trunk in r88769. Please review and let me know of any changes. I'll merge to stage on Monday pending feedback.
Keywords: qawanted
(In reply to comment #10)
> Done in trunk in r88769. Please review and let me know of any changes. I'll
> merge to stage on Monday pending feedback.

hi steven, can you please provide the link to the trunk to review. thanks
(In reply to comment #11)
> hi steven, can you please provide the link to the trunk to review. thanks

https://www-trunk.stage.mozilla.com/en-US/mobile/download/
(In reply to comment #12)
> (In reply to comment #11)
> > hi steven, can you please provide the link to the trunk to review. thanks
> 
> https://www-trunk.stage.mozilla.com/en-US/mobile/download/

hi steven, 

thanks. looks good. a few minor additions:
*please add release notes link under final release for android download button: http://www.mozilla.com/mobile/4.0/releasenotes/
*add release notes link under the download beta for android button: http://www.mozilla.com/mobile/4.0/releasenotes/

* lastly, link to android market for beta is tbd. will provide ASAP. 

thanks!
Added release notes to trunk at Grace's request in r88853. They look a bit awkward as the page was designed without them and there are already other link styles under the buttons. This will probably have to do for today, but we could potentially improve their appearance later one (or eliminate them, as we did on desktop download buttons).

Please note that the release notes links are generated by the product-details library and will be automatically updated to the latest_version and beta_version numbers when the library is updated (who does that?).
(Reporter)

Comment 15

7 years ago
I am not sure -- maybe Stuart? Christian or Thomas - can you assist with this?
(Assignee)

Comment 16

7 years ago
I do product-details for Desktop and also help Stuart out when mobile needs it.
(In reply to comment #16)
> I do product-details for Desktop and also help Stuart out when mobile needs
> it.

hi christian. Stuart is out and would need your help on this one. what's the next steps?
(Assignee)

Comment 18

7 years ago
If the page is done we can break this out to a different bug for updating product-details.
qa-verified-stage http://www-trunk.stage.mozilla.com/en-US/mobile/download/
Keywords: qawanted
(Reporter)

Comment 20

7 years ago
Christian - We need to stage the release notes. Can you help format re Comment 14?
(Reporter)

Comment 21

7 years ago
(In reply to comment #19)
> qa-verified-stage http://www-trunk.stage.mozilla.com/en-US/mobile/download/

The Release Notes under Beta links to the wrong rel notes.
I'm re-assiging to Christian as the only remaining issue is the version number in the release notes link, which comes from the product-details lib.
Assignee: steven → clegnitto
(Assignee)

Comment 23

7 years ago
(In reply to comment #21)
> (In reply to comment #19)
> > qa-verified-stage http://www-trunk.stage.mozilla.com/en-US/mobile/download/
> 
> The Release Notes under Beta links to the wrong rel notes.

Yeah....this is a fun little dance because input.mozilla.org pulls from product-details trunk (I have some bug filed somewhere).
new live date: thursday, 5/19
Target Milestone: 2.5 → ---
Updated with the real Mobile Beta android market link in trunk in r89001.

Christian, I presume you'll be merging this stuff to stage/production? All of my revisions are noted here in the bug comments.
Steven, I added a function `android_web_link` to the mobile product-details class to convert a market:// url to a http:// url. So if you choose to use that url, you can do so by:

mobileDetails::android_web_link(mobileDetails::download_link(...))

I'm open to suggestion for improving it, but the download function already has a lot of parameters so I didn't want to bloat it more. 

I've changed the link on the /channel page to use this in:

r89051
Merged all changes from this bug to stage in r89069.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
'Release Notes' link in the Beta download box points to the 4.0rc1 release notes. http://www-trunk.stage.mozilla.com/en-US/mobile/4.0rc1/releasenotes
(Assignee)

Comment 30

7 years ago
(In reply to comment #29)
> 'Release Notes' link in the Beta download box points to the 4.0rc1 release
> notes. http://www-trunk.stage.mozilla.com/en-US/mobile/4.0rc1/releasenotes

See comment 23, expected until product-details are updated.
pushed to production r89178
verified fixed http://www.mozilla.com/en-US/mobile/download/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.