Last Comment Bug 652731 - Remove check for ZIP in js/src configure, since spidermonkey does not require it
: Remove check for ZIP in js/src configure, since spidermonkey does not require it
Status: RESOLVED FIXED
wanted-standalone-js
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-25 18:23 PDT by Ed Morley [:emorley]
Modified: 2011-10-06 12:08 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove js/src configure & autoconf ZIP/UNZIP references (2.54 KB, patch)
2011-04-25 18:56 PDT, Ed Morley [:emorley]
jimb: review+
Details | Diff | Splinter Review
Remove js/src configure & autoconf ZIP/UNZIP references (1.94 KB, patch)
2011-05-12 14:05 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-04-25 18:23:04 PDT
Per Wes' request...

Building spidermonkey standalone requires ZIP be present (http://mxr.mozilla.org/mozilla-central/source/js/src/configure.in#979), even though it's not used / needed for the build to complete. This results in delightful workarounds along the lines of:
ln -s /bin/true /bin/zip

...on every new machine used; so Wes would like the check removed.

Occurrences of ZIP in /js/src:
http://mxr.mozilla.org/mozilla-central/search?string=ZIP&find=/js/src/&case=on

Of those, jsconfig.mk is being removed in bug 647388 and the rules.mk entry is only used for chrome packaging, so is only there to keep check-sync-dirs happy. Therefore the check for ZIP is indeed superfluous.
Comment 1 Ed Morley [:emorley] 2011-04-25 18:29:09 PDT
Doh, the two MXR links should be the other way around...
Comment 2 Ed Morley [:emorley] 2011-04-25 18:56:04 PDT
Created attachment 528250 [details] [diff] [review]
Remove js/src configure & autoconf ZIP/UNZIP references

Seeing as I was removing the ZIP check, it seemed sensible to just remove the ZIP defines & MOZ_PATH_PROGS altogether, since none of it is used. Plus this way if spidermonkey ever requires ZIP in the future, putting the check back in won't be forgotten. Also removed UNZIP, since it's not used either.

ZIP: 
http://mxr.mozilla.org/mozilla-central/search?string=ZIP&find=/js/src&case=on

UNZIP:
http://mxr.mozilla.org/mozilla-central/search?string=UNZIP&find=/js/src&case=on
Comment 3 Ed Morley [:emorley] 2011-04-25 19:20:47 PDT
Ok, this time it wasn't me! The swapped links in comment 2 are due to some weird BMO bug, have filed bug 652740.
Comment 4 Ed Morley [:emorley] 2011-04-26 01:24:22 PDT
Sorry for the spam, but bug 652740 (BMO auto linkification swapping links around) has been fixed, so the comments above are now displaying correctly.

As such, please disregard comment 1 and comment 3.
Comment 5 Ed Morley [:emorley] 2011-05-02 16:46:57 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=1974491cd478
Comment 6 Ed Morley [:emorley] 2011-05-11 07:47:58 PDT
Jim, ping for review please :-)

Thanks!
Comment 7 Jim Blandy :jimb 2011-05-12 12:44:47 PDT
Comment on attachment 528250 [details] [diff] [review]
Remove js/src configure & autoconf ZIP/UNZIP references

Review of attachment 528250 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Comment 8 Ed Morley [:emorley] 2011-05-12 14:05:00 PDT
Created attachment 532022 [details] [diff] [review]
Remove js/src configure & autoconf ZIP/UNZIP references

Updated to tip, carrying forwards r+.

Thanks for the review :-)
Comment 9 Matt Brubeck (:mbrubeck) 2011-05-13 07:04:00 PDT
http://hg.mozilla.org/mozilla-central/rev/9260062de89b

Note You need to log in before you can comment on or make changes to this bug.