Closed Bug 652757 Opened 9 years ago Closed 9 years ago

Auto linkification of "attachment X" occurs across newlines, rendering numbered STR unreadable

Categories

(bugzilla.mozilla.org :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 105865

People

(Reporter: emorley, Unassigned)

Details

No description provided.
Doh, posting bug fail.

In bug 652740 comment 0, my numbered STR have been rendered unreadable due to 	bug 514703, since the word "attachment" on the line before, causes the next numbered step to turn into an attachment link.

Whilst auto-linkification across newlines is no doubt helpful in some circumstances (hence the point of bug 514703), for "attachment" in particular, it's quite disruptive, since it not only turns the text into a clickable link, but also changes the wording too (the STR in bug 652740 comment 0 doesn't make any sense as a result).

Perhaps as a compromise, the regex for "attachment X" could be adjusted so that it doesn't match on a single digit on a newline?
And this has been the case forever, see bug 105865. Nothing new here. Unrelated to the upgrade.
No longer blocks: bmo-regressions
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 105865
No longer blocks: 514703
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.