Closed Bug 652766 Opened 9 years ago Closed 9 years ago

Style Inspector breaks when stylesheets are switched

Categories

(DevTools :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 653082

People

(Reporter: miker, Assigned: miker)

References

Details

(Whiteboard: [dupeme])

Switch stylesheets in the Style Inspector's dropdown and then nothing is available under any style groups.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
More accurately, to reproduce this:
1. Expand any style group
2. Change the stylesheet.

The group will then be empty and switching back will not recover the properties.
This doesn't surprise me at all.

We should probably consider taking out the switcher for now. I think this was probably a nice-to-have feature that we could have been more brutal with at the time.
We just failed to reset the groups when the stylesheet was changed. I believe that calling reset for each group will fix it.
I have fixed this in the Style Inspector's source but now see what you mean. Because we are using calculated styled we can't really limit the result to just a single sheet and, besides, it really is confusing to the user.

I will log another bug for removal.
maybe remove it or pref it out?

Also would suggest having a unittest for it demonstrating these problems.
is this now a dupe of bug 653082?
Whiteboard: [dupeme]
Yup, it is
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Depends on: 582596
Resolution: --- → DUPLICATE
Duplicate of bug: 653082
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.