Closed Bug 652872 Opened 9 years ago Closed 9 years ago

Prints text as rasterized image instead of text

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 638764

People

(Reporter: abcdzywx, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

When printing any webpage from Firefox 4 to Adobe PDF using PDF Printer, the resulting document is a completely flat rasterized image, including text.  Firefox 4 is rasterizing the text to an image before sending it to a printer, so text cannot be selected, copied, edited, etc. in the resulting document.  The document takes up a lot of space because it is a complete image.  If we wanted to print a page as an image that would be a nice option or we could use an image printer, but for general printing usage, text should be printing as vector text in the appropriate font.

Reproducible: Always

Steps to Reproduce:
1. Print a page to PDF.
2. Open the PDF.
3. Try selecting text, copying, etc.
4. Try steps 1-3 in Internet Explorer instead.

Actual Results:  
The document printed from Firefox 4 is entirely an image and you cannot select, copy, or manipulate text.  When printed from IE, the document is normal and text appears as "real" text.

Expected Results:  
Text should print as text and not be rasterized to an image.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638764
You need to log in before you can comment on or make changes to this bug.