Closed Bug 652902 Opened 9 years ago Closed 9 years ago

"646184.html | assertion count 0 is less than expected 1 assertions"

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: sgautherie, Unassigned)

References

()

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303842900.1303843272.6190.gz
Rev3 Fedora 12 mozilla-central debug test crashtest on 2011/04/26 11:35:00
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303843208.1303843575.7317.gz
Rev3 Fedora 12x64 mozilla-central debug test crashtest on 2011/04/26 11:40:08

Don't know yet if that's random or caused/"fixed" by
http://tbpl.mozilla.org/?rev=28bc239d3d9d
When someone breaks the tree, you don't just file a bug and land anyway.
This is one more problem caused by you not being around on IRC, Serge.

(In reply to comment #0)
> Don't know yet if that's random or caused/"fixed" by
> http://tbpl.mozilla.org/?rev=28bc239d3d9d

Then you shouldn't have landed on top of this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> When someone breaks the tree, you don't just file a bug and land anyway.

I'm sorry, I didn't think the comment removal patch I landed would make any
difference wrt the failure reported here.

Maybe the tree should be closed if the policy is to wait for tracemonkey merge
outcome before doing new checkins.


(In reply to comment #2)

> This is one more problem caused by you not being around on IRC, Serge.

Blame accepted, record it as such.

> (In reply to comment #0)
> > Don't know yet if that's random or caused/"fixed" by
> > http://tbpl.mozilla.org/?rev=28bc239d3d9d
> 
> Then you shouldn't have landed on top of this.

Not to restarted arguments that happened a long time ago, and in addition to
what I told you by email recently, let me say that I'll just wait for a hopeful
checkin-needed for so trivial patches too from now on.
OS: Linux → All
Hardware: x86 → All
I CAN'T BELIEVE IT:
YOU DO COMPLAIN TO ME BECAUSE I LANDED A HARMLESS PATCH
AND BECAUSE I DIDN'T STAR QUICK ENOUGH TO YOUR LIKING (see bug 652862)
THEN YOU OVER-STAR THE ORANGE BUILDS WITH "Ignore what Serge said"
AND MARK THIS BUG AS "INVALID":
I DON'T GET THE JOKE VERY NICELY. PLEASE, NEVER AGAIN TELL ME TO CARE (which I was doing) TO CHECK TREE AND FILE BUGS LIKE THIS ONE :-[
THIS JUST SO MUCH CONFIRMS THE NON-SENSE THAT MADE ME REDUCE MY CONTRIBUTION TO A MINIMUM.
Let's not yell at each other in capitals, please.

(In reply to comment #4)
> I CAN'T BELIEVE IT:
> YOU DO COMPLAIN TO ME BECAUSE I LANDED A HARMLESS PATCH

No, I do complain to you because you ignore tree rules, shortly after I brought it to your attention, and you agreed to pay more attention to them.

> AND BECAUSE I DIDN'T STAR QUICK ENOUGH TO YOUR LIKING (see bug 652862)

Whether I like something or not doesn't matter.  You're missing the point of starring oranges.  See bug 652862 comment 6.

> THEN YOU OVER-STAR THE ORANGE BUILDS WITH "Ignore what Serge said"

Yes, because the bug you filed was invalid, and I didn't want to leave the incorrect comments on the build logs.  They may confuse others.

> AND MARK THIS BUG AS "INVALID":

This bug is invalid as it is filed.  We don't file bugs for unexpected breakages like this one: we either fix the bug quickly on mozilla-central (which is what happened in this case) or back out the patch which caused the bug.

> I DON'T GET THE JOKE VERY NICELY.

Nobody is joking here, I don't think.  People are just going to remind you of the tree rules once again.

> PLEASE, NEVER AGAIN TELL ME TO CARE (which I
> was doing) TO CHECK TREE AND FILE BUGS LIKE THIS ONE :-[

If you don't want to care about the tree rules, you should refrain from landing on mozilla-central.

> THIS JUST SO MUCH CONFIRMS THE NON-SENSE THAT MADE ME REDUCE MY CONTRIBUTION TO
> A MINIMUM.

I certainly do not appreciate your tone here, and I'm sorry that you feel this way, but there are a large number of people who land patches while observing the tree rules, so I believe your unwillingness to do so can not be attributed to the tree rules.
(In reply to comment #5)

> Let's not yell at each other in capitals, please.

I just used bug 652862 comment 2 style...

> No, I do complain to you because you ignore tree rules, shortly after I brought
> it to your attention, and you agreed to pay more attention to them.

And I kept my checkins to almost zero, as I told you I would do.

> This bug is invalid as it is filed.  We don't file bugs for unexpected
> breakages like this one: we either fix the bug quickly on mozilla-central
> (which is what happened in this case) or back out the patch which caused the
> bug.

Then, if the failure was so quickly fixed, why ASK me to star (hence to file new bugs as needed) and why all that fuss?

> If you don't want to care about the tree rules, you should refrain from landing
> on mozilla-central.

Didn't I wrote I would fully do that in comment 3?

> there are a large number of people who land patches while observing
> the tree rules

What about those who don't? What about bug 626561 and bug 632433 for example?
It feels non-sense to me because I'm the culprit for doing checkins that succeed while others are allowed to leave breakages in the tree for months :-<
(In reply to comment #6)
> (In reply to comment #5)
> 
> > Let's not yell at each other in capitals, please.
> 
> I just used bug 652862 comment 2 style...

Yelling at people when you make a mistake is impolite, to say at least.  I'm sure David was just frustrated because we've been going back and forth with you on this for quite some time.

> > No, I do complain to you because you ignore tree rules, shortly after I brought
> > it to your attention, and you agreed to pay more attention to them.
> 
> And I kept my checkins to almost zero, as I told you I would do.

You need to observe the tree rules every time you check in.  Whether it's once a year or 10 times per day makes no difference.

> > This bug is invalid as it is filed.  We don't file bugs for unexpected
> > breakages like this one: we either fix the bug quickly on mozilla-central
> > (which is what happened in this case) or back out the patch which caused the
> > bug.
> 
> Then, if the failure was so quickly fixed, why ASK me to star (hence to file
> new bugs as needed) and why all that fuss?

I refuse to engage in going back and forth with you about this.  The tree rules are clear.  If you do not agree with them, or do not want to follow them, you should not land on mozilla-central at all.  If you have questions whether you can land something at any given point in time, you should check with the sheriff, or ask on #developers.  Really, there is absolutely no ambiguity here, and everybody seems to realize what they're supposed to do.  I've explained this to you before, and nothing has changed since then.

> > If you don't want to care about the tree rules, you should refrain from landing
> > on mozilla-central.
> 
> Didn't I wrote I would fully do that in comment 3?

OK.

> > there are a large number of people who land patches while observing
> > the tree rules
> 
> What about those who don't? What about bug 626561 and bug 632433 for example?
> It feels non-sense to me because I'm the culprit for doing checkins that
> succeed while others are allowed to leave breakages in the tree for months :-<

It is not a matter of whether what you land is all green or not.  Like I said, the tree rules are clear.  Please read the document instead of randomly blaming other people for things which have absolutely no relevance to the topic in question.

And I respectfully refuse to answer any more comments on this topic.  You can always ask other people if you have more questions.

Thank you.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.