Closed Bug 652915 Opened 9 years ago Closed 8 years ago

Automatically notify metrics team about new releases

Categories

(Release Engineering :: Release Automation: Other, defect, P5)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 577696

People

(Reporter: rail, Unassigned)

Details

(Whiteboard: [releases][automation])

According to the new work flow releng need to send a notification to the metrics team about new releases when we start the release. Probably when we start tagging and only for buildNumber == 1.

Example email:

From: release@m.c
To: metrics@m.c
Subject: [release] Firefox 3.6.16

Firefox,firefox,firefox,3.6.16,3.6
Firefox,firefox,firefox,3.6.17pre,3.6
Found in triage - marking p5 until we can find someone to work on this.
Priority: -- → P5
(In reply to comment #2)
> According to the new work flow releng need to send a notification to the
> metrics team about new releases when we start the release. Probably when we
> start tagging and only for buildNumber == 1.
Sounds good, Rail.

Daniel and I just talked, both agree to RelEng sending notice to Metrics at start of build process, like right before/after tagging (not waiting for "go to beta").
Some notes regarding the data in the e-mail:

We need to make sure that the full version that is listed in the comma separated lines always matches exactly what would appear in the blocklist ping's APP_VERSION variable and also the version number that would appear in the bouncer URL's product parameter.  If these version numbers were ever to disagree for some reason, file a blocker bug for metrics with details so we can sort out what to do.

As context in the e-mail, it would be useful for us to be notified about the channel that a particular release is part of.  We don't have a column for that in the data specification, but if you could just mention it in text, it will help us to be aware if we need to update a section of the nightly report to track a new aurora version, etc.

Here is an example e-mail to give a sense of what I mean.  It is just a suggestion though.  If there is a format that makes more sense or is easier let me know.

From: release@m.c
To: metrics@m.c
Subject: [release] Firefox 5.0

Firefox 5.0 has been released to the beta channel:
 Firefox,firefox,firefox,5.0,5.0

Firefox 6.0 has been released to the aurora channel:
 Firefox,firefox,firefox,6.0b1,6.0
(In reply to comment #3)
> As context in the e-mail, it would be useful for us to be notified about the
> channel that a particular release is part of.

We can certainly do this for beta and release builds, but not easily for aurora as the release automation isn't used there. 

I think the email should actually be
 A Firefox 5.0 build has been created on the beta channel:
  Firefox,firefox,firefox,5.0,5.0

 The aurora channel is now 6.0a2:
  Firefox,firefox,firefox,6.0a2,6.0

 The nightly channel is now 7.0a1
  Firefox,firefox,firefox,7.0a1,7.0

ie 6.0a2 for aurora, different wording, add nightly. These wouldn't necessarily all come on the same day, depends when the merges are done. Would you want something for '5.0' making it to release ? It'd be the same CSV as beta. 

These notifications really look like something someone doing the merges would be best placed to do, because our automation only has visibility to beta. But it would be useful if we notify you of the buildID for every set of builds we do on beta/release. I'm anticipating release-drivers will make a request to split (eg) 5.0 into the different beta/release builds at some point, and it would be good to have that data on hand already.
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: hg-automation
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577696
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.