Closed Bug 652965 Opened 11 years ago Closed 11 years ago

Firefox 5.0a2 Crash Report [@ js_GCThingIsMarked(void*, unsigned int) ]

Categories

(Core :: JavaScript Engine, defect)

5 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 650519

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

Seen while reviewing Aurora crash stats. http://tinyurl.com/3rl6rly to the crashes in the last week. This crash occurs on the trunk and 4.0.x as well. #5 Top crash on Aurora.

https://crash-stats.mozilla.com/report/index/7850455b-1389-4031-8b1f-f0f942110426

One comment mentions https://addons.mozilla.org/en-US/firefox/addon/febe/

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js_GCThingIsMarked 	js/src/jsgc.cpp:523
1 	xul.dll 	GCGraphBuilder::NoteScriptChild 	xpcom/base/nsCycleCollector.cpp:1680
2 	xul.dll 	xul.dll@0xc69a7b 	
3 	xul.dll 	NoteChild 	obj-firefox/xpcom/build/nsCycleCollectionParticipant.cpp:46
4 	xul.dll 	nsJSArgArray::cycleCollection::Trace 	dom/base/nsJSEnvironment.cpp:4001
5 	xul.dll 	nsJSArgArray::cycleCollection::Traverse 	dom/base/nsJSEnvironment.cpp:3988
6 	xul.dll 	xul.dll@0xcd0e27 	
7 	xul.dll 	nsCycleCollector::MarkRoots 	xpcom/base/nsCycleCollector.cpp:1773
8 	xul.dll 	nsCycleCollector::BeginCollection 	xpcom/base/nsCycleCollector.cpp:2636
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650519
Crash Signature: [@ js_GCThingIsMarked(void*, unsigned int) ]
You need to log in before you can comment on or make changes to this bug.