Closed Bug 65298 Opened 19 years ago Closed 6 years ago

MailNews doesn't display message whose account folder is located on a network drive.

Categories

(MailNews Core :: Networking, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: peter.oshea, Unassigned)

References

Details

1. Set up a mail account with the folder location on a networked drive.
e.g.:
\\Main_pc\main_disk\WINDOWS\Profiles\Peter\Application
Data\Mozilla\Users50\default\Mail\pop.ne.mediaone.net

2. Start MailNews.
3. Select a folder and a message on the networked account.
4. The message in the header pane is highlighted, and the window title changes
to the message subject, but the message display pane stays blank.
Reporter what build id are you using? What OS? Have you tried upgrading to the
latest nightlies and creating a new profile? Does that fix the problem?
This was occurring with builds as recent as approx. 20010117.  I'll check with
the latest available builds.  The OS is Win98/WinME.  I haven't tried creating a
new profile.

To make it hopefully a bit clearer, I'm running Moz on a WinME machine and
downloading mail normally.  I then close Mozilla on that machine and go to a
laptop networked to the first machine.  I run Mozilla on the laptop, set up a
mail profile which has a folder location pointing to the network location of the
first machine.  MailNews will display the folders and message headers correctly,
but won't display the message contents.

Would it help if I attached the profile files for the two machines?
First try creating a new profile and if it fixes it then there is no need to
attach a profile. Please respond either way :)
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Marking WORKSFORME due to lack of response. Reopen if we get more information.
Ksosez, you shouldn't resolve just because of "lack of response" (unless it has
gone a lot of time since last response from reporter), unconfirmed bugs are
there for a reason!

And I really don't think that 2 weeks is lack of response! Also, you shouldn't
mark wfm unless you actually can reproduce it, reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Ack, that should be "unless you actually can't reproduce it".
Ok, I installed build 2001020904 for Windows on both machines, created new
profiles on each machine, and it still doesn't work.
Steps to reproduce:
1. Set up Mozilla and profile on machine A, including email account.
2. Set up Mozilla and profile on machine B, including same email account.
3. Change directory for account on machine B to point to machine A (on network).
4. Get a few emails in Inbox on machine A.  Close Mozilla.
5. Run Mozilla on machine B.  In MailNews, look at Inbox.
6. Message summaries will correctly appear in upper-right window.
7. Click on a summary to display it.
8. The title of the MailNews window will change to the subject of the message,
but the message contents won't display in the lower-right window.
setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is there any chance this bug will get looked at?  There must be lots of other
people like me who have a small home network and want to be able to read and
reply to mail from different computers, but have the mail stored on one hard drive.
OS: other → Windows 98
You may (since 0.9.3) be able to access your mail using the "file://///" syntax
described in bug 66194.
Depends on: 66194
No longer depends on: 66194
Depends on: 101953
Blocks: 101953
No longer depends on: 101953
Closing bug after two years.  I don't:
1. Use mozilla mail anymore.
2. Use windows anymore.

Therefore I can't test.
Status: NEW → RESOLVED
Closed: 19 years ago17 years ago
Resolution: --- → WONTFIX
actually I think this might have gotten fixed in the meantime, when nsFileSpec
got fixed to work with unc paths...
indeed
\Device\LanmanRedirector\raistlin\F$\Documents and
Settings\Administrator.RAISTLIN\Application
Data\Mozilla\Profiles\two\4mcry0xm.slt\Mail\Local Folders\Sent.msf
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
it's still broken, 2003062004 w2k
note that the path in prefs is 
\\raistlin\F$\Documents and Settings\Administrator.RAISTLIN\Application
Data\Mozilla\Profiles\two\4mcry0xm.slt\Mail\Local Folders

(The path I pasted in the previous comment is Process Explorer showing mozilla
with an open file, the Sent Folder)

The original description is accurate.
Severity: normal → major
Product: MailNews → Core
Assignee: mscott → nobody
Status: REOPENED → NEW
QA Contact: esther → mailnews.networking
Product: Core → MailNews Core
I don't believe this still exists
Flags: needinfo?(peter.oshea)
Summary: MailNews doesn't display message located on a network drive. → MailNews doesn't display message whose account folder is located on a network drive.
(I clicked in the wrong places)
Status: NEW → RESOLVED
Closed: 17 years ago6 years ago
Flags: needinfo?(peter.oshea)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.