Last Comment Bug 653001 - Replace about-logo.png with optimized version
: Replace about-logo.png with optimized version
Status: RESOLVED FIXED
: footprint
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 23
Assigned To: Frédéric Kayser
:
Mentors:
http://mxr.mozilla.org/mozilla2.0/sou...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 16:38 PDT by Frédéric Kayser
Modified: 2015-02-13 13:10 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
about-log.png (firefox branding) optimized (48.61 KB, image/png)
2011-04-26 16:40 PDT, Frédéric Kayser
no flags Details
about-log.png (firefox branding) optimized (48.34 KB, image/png)
2011-09-28 17:42 PDT, Frédéric Kayser
no flags Details
about-logo.png (firefox branding) optimized patch file (62.67 KB, patch)
2011-09-28 18:14 PDT, Frédéric Kayser
fryn: review+
Details | Diff | Splinter Review

Description Frédéric Kayser 2011-04-26 16:38:10 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

In a effort to reduce the size of omni.jar and Firefox footprint, I offer you to replace current bloated images with pixel perfect identical ones that have been optimized using various tools (cryopng, pngout, pngwolf, deflopt and defluff) a lot of CPU cycles and a bit of luck.

File location in source:
mozilla-2.0/other-licenses/branding/firefox/content/about-logo.png

Ends up here:
omni.jar!/chrome/browser/content/branding/about-logo.png

Sizes
original:  55620 bytes
optimized: 49776 bytes
saved:      5844 bytes (more than 10%)

This bug report is a follow-up of Bug 631392

Reproducible: Always
Comment 1 Frédéric Kayser 2011-04-26 16:40:45 PDT
Created attachment 528480 [details]
about-log.png (firefox branding) optimized
Comment 2 Frédéric Kayser 2011-09-28 17:42:25 PDT
Created attachment 563253 [details]
about-log.png (firefox branding) optimized

Even smaller file (used current version of pngout and huffmix to reduce size)
Comment 3 Frédéric Kayser 2011-09-28 18:14:48 PDT
Created attachment 563264 [details] [diff] [review]
about-logo.png (firefox branding) optimized patch file

The new .png file size is 49502 bytes (6118 bytes smaller than the original - 10% smaller).
Comment 4 Justin Dolske [:Dolske] 2011-10-11 04:07:22 PDT
As I noted over in bug 631392, I'd rather we find a more general solution to this than tweaking images one by one. (That said, I'm fine with taking this bug since it was already in-flight when the discussion in 631392 happened.)
Comment 5 Frank Yan (:fryn) 2013-04-16 15:28:27 PDT
Comment on attachment 563264 [details] [diff] [review]
about-logo.png (firefox branding) optimized patch file

Review of attachment 563264 [details] [diff] [review]:
-----------------------------------------------------------------

I just realized that we use this on about:home, since it affects every about:home load.
Looks good to land. I don't see any reason to keep this trivial two-year-old bug open any longer.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-04-17 10:01:58 PDT
https://hg.mozilla.org/mozilla-central/rev/041e81903b53
Comment 8 Eric 2015-02-13 13:10:11 PST
The @firefox.exe icon is badly compressed; would shrink 31% if recompressed with Zopfli. (Chrome's shrinks 38 bytes.) pic.twitter.com/PuRXURJKwU

Note You need to log in before you can comment on or make changes to this bug.