Flash cookies are not cleared when using the "remove individual cookies" UI

RESOLVED DUPLICATE of bug 645080

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 645080
7 years ago
7 years ago

People

(Reporter: kev, Unassigned)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Adobe Flash 10.3 and above supports removal of its cookies (Locally Shared Objects (LSO)) via NSAPI calls. When using the "Clear your recent history" UI in Firefox's Privacy preferences, these cookies are removed as expected when cookies are sected. When using the "remove individual cookies" UI to remove cookies site-by-site, Flash cookies are not removed. Flash cookies should be removed/cleared using both methods.

The RC of Flash 10.3 can be obtained from http://labs.adobe.com/downloads/flashplayer10-3.html

Steps to Reproduce:

1) View any website that sets a Flash LSO/Cookie (e.g. YouTube) and verify that the cookie has been written to disk. Flash cookies are stored in the following directories by platform:

Windows: ~\Application Data\Macromedia\Flash Player
OSX: ~/Library/Preferences/Macromedia/Flash Player
GNU-Linux: ~/.macromedia

2) Open Preferences/Options and select the Privacy pane

3) Select "remove individual cookies"; the Cookies dialog will open

4) Select the hostname that corresponds with the cookie set in step 1, and click on the "Remove Cookies" button

Actual Results: Cookies set within Firefox are cleared, but Flash's LSO/Cookies are not. 

Expected Results: Cookies set within Firefox and by Flash for that hostname should both be cleared.

Build Date & Platform: Build 20110318052756 on Mac OS 10.6.7
Dupe of Bug 645080?

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645080
You need to log in before you can comment on or make changes to this bug.