If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lots of views in dashboards.views need @login_required

VERIFIED FIXED in 2.8.2

Status

support.mozilla.org
Users and Groups
P2
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: jsocol, Assigned: rrosario)

Tracking

unspecified
2.8.2

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
For example:

'PATH_INFO': u'/en-US/dashboard/forums'

Traceback (most recent call last):

  File "/data/www/support.mozilla.com/kitsune/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/support.mozilla.com/kitsune/vendor/src/django/django/views/decorators/http.py", line 37, in inner
    return func(request, *args, **kwargs)

  File "/data/www/support.mozilla.com/kitsune/apps/dashboards/views.py", line 89, in review
    {'actions': model_actions(Post, request),

  File "/data/www/support.mozilla.com/kitsune/apps/dashboards/utils.py", line 17, in model_actions
    actions = request.user.action_inbox.filter(content_type=ct)

AttributeError: 'AnonymousUser' object has no attribute 'action_inbox'
(Reporter)

Updated

7 years ago
Duplicate of this bug: 653020
(Assignee)

Updated

7 years ago
Assignee: nobody → rrosario
(Assignee)

Comment 2

7 years ago
https://github.com/jsocol/kitsune/commit/210991b2b401663e45779e5db92003aa38579b28
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: 2011Q2 → 2.8.2
http://support.allizom.org/en-US/dashboard/forums is still triggering a traceback (from dupe bug 653020):

Traceback (most recent call last):

  File "/data/www/support.allizom.org/kitsune/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/support.allizom.org/kitsune/vendor/src/django/django/views/decorators/http.py", line 45, in inner
    return func(request, *args, **kwargs)

  File "/data/www/support.allizom.org/kitsune/apps/dashboards/views.py", line 89, in review
    {'actions': model_actions(Post, request),

  File "/data/www/support.allizom.org/kitsune/apps/dashboards/utils.py", line 17, in model_actions
    actions = request.user.action_inbox.filter(content_type=ct)

AttributeError: 'AnonymousUser' object has no attribute 'action_inbox'
(Assignee)

Comment 4

7 years ago
I probably missed the forums dashboard.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

7 years ago
Now the forums ("Review") dashboard is protected as well:
https://github.com/jsocol/kitsune/commit/060ff48442961c3a07bc6bde5daabb73815fc37f
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Verified dashboard/forums does not trigger tracebacks on either support.allizom or support-release
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.