Closed Bug 65322 Opened 19 years ago Closed 19 years ago

Separators in Personal Toolbars is displayed incorrectly

Categories

(SeaMonkey :: Bookmarks & History, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9

People

(Reporter: hwaara, Assigned: bugzilla)

References

Details

(Keywords: helpwanted)

Attachments

(1 file)

Some time ago I could have separators in my Personal Toolbar; I just created a
new separator in the "Manage Bookmarks" window and then dropped it between a few
folders/bookmarks in the personal toolbar folder.

This is somehow broken now, a separator in the Personal Toolbar now show up as
usual bookmark with "----" as its name or "" (blank) as its name.

Steps to reprocuce:

1. Go to Bookmarks/Manage Bookmarks...
2. Go to Create/New Separator
3. Place this new separator in your Personal Toolbar folder
4. Look at it in the actual Personal Toolbar

WARNING: I think this bug only affects separators which is in the Personal
Toolbar folder, and not a subfolder to it.
Confirming on Linux ... I get an empty bookmark in the toolbar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All
Why does the separator between Home and The Mozilla Organisation show up
correctly? This is also broken in mozilla0.7 win32.
Fabian: because the code which creates that separator is bug-free, which is not
the case here..
This looks like a duplicate of 41885.
Yes. But it *was* actually implemented some time after the last comment on that
bug, so it might be a regression even though that bug never was FIXED?

I'm confused.
I ben's busy, so I'm adding the 'helpwanted' keyword. I want this fixed ASAP.
Keywords: helpwanted
Marking nsbeta1+, p3, mozilla0.9, reassigning to pchen because he thinks it's
annoying too.
Assignee: ben → pchen
Keywords: nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9
Attached patch patchSplinter Review
sr=alecf
dragged pinkerton into my cube to review, r=pinkerton
Reassigning to blake since he's the one that came up with the fix, and he's not 
handcuffed by commercial tree rules
Assignee: pchen → blakeross
Fix checked in.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
VERIFIED Fixed on all platforms with the 2001042608 builds.
Status: RESOLVED → VERIFIED
*** Bug 41885 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.