Fewer than 6 featured add-ons are shown when you have a featured add-on installed

RESOLVED FIXED in Q2 2011

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: cvan)

Tracking

unspecified
Q2 2011

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 528759 [details]
screenshot

steps to reproduce:
1. Load disco pane in next(or load http://tinyurl.com/3enpgyo)
2. Notice the featured add-ons module

observed behavior:
Featured add-ons module has fewer than 6 add-ons. Without recommendations, there are 6 add-ons( https://addons-next.allizom.org/en-US/firefox/discovery/pane/4.0/Darwin). See screenshot

Also, see bug 638696
I approve of this use of fewer.
Created attachment 528780 [details]
screenshot

I loaded the link in comment 0 in a nightly and it looks fine (see attachment)
Target Milestone: 6.0.8 → 6.0.9
Need help to confirm this.  Did I do something wrong?  I was using linux - maybe that matters?
Status: NEW → UNCONFIRMED
Ever confirmed: false
Target Milestone: 6.0.9 → Q2 2011
(Reporter)

Comment 4

8 years ago
Wil, try this-

steps to reproduce:
1. Load disco pane in next(or load http://tinyurl.com/3enpgyo)
2. Install one of the featured add-ons
3. reload the page (just to be sure, give it 10 minutes)

expected  behavior:
Featured add-ons module has 6 add-ons (the installed add-on is replaced by some other featured add-on.)

actual behavior:
Featured module has only 5 add-ons.
I don't think the steps to reproduce would change anything - that list should be built by what is in the URL (the stuff after the hash), so installing or reloading shouldn't change what is listed there.

Cvan wrote the logic, so CCing him.
(Assignee)

Comment 6

8 years ago
I can't reproduce this. As long as you're using a different URL (with a different hash) after you've installed the add-on, then you should be seeing 6 add-ons.

Comment 7

8 years ago
could reproduce this, checked on windows xp as follows:
1)Installed "Tab Scope" from Featured add-ons list
Note: this is one among 6 add-ons listed in Featured add-ons section
2)Reload or close and open Tools->Add-ons

Observed Result: Featured add-ons shows 5 add-ons. Installed add-on is not replaced by other add-on and placeholder is empty

Comment 8

8 years ago
Created attachment 529420 [details]
screenshot displays Discover Pane UI showing 5 add-ons after adding one of the Featured add-on

Updated

8 years ago
Summary: Fewer than 6 featured add-ons are shown when there are recommendations → Fewer than 6 featured add-ons are shown when you have a featured add-on installed
Reloading the link in comment 0 or reopening tools->add-ons will be the difference between this working and not.  Which did you do?  Can you reproduce this by closing the tab and reopening tools->add-ons?  What if you restart Firefox?
(Assignee)

Comment 10

8 years ago
https://github.com/jbalogh/zamboni/commit/c69843e
Assignee: nobody → cwiemeersch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.