cannot login in jira at metrics.mozilla.com/projects using ldap password

RESOLVED INVALID

Status

mozilla.org Graveyard
Server Operations
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: TGF, Assigned: dumitru)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

Two days ago (april 26) could login to https://metrics.mozilla.com/projects/login.jsp using tferreira@mozilla.com as user and my ldap account password. 
Today it wasn't working (in the meantime extra permissions were set for the jira account). Tried resetting the password, new one wouldn't work.
Account was deleted and recreated, but still not able to log in.


Reproducible: Always


Actual Results:  
«Sorry, your username and password are incorrect - please try again. »
JIRA is configured to not store a password and to use LDAP to authenticate all requests. I was monitoring the logs when he attempted to sign in:
cm-metricsapp01:/opt/jira42/log/atlassian-jira-security.log

And it gives the same error that one gets if they pass in an invalid password.  He was able to sign in with the same password to Intranet.

Was hoping you guys could look at things from the LDAP side and give us a hint what might be going on.

Especially odd since he was able to log in twice yesterday without a problem.
(Assignee)

Updated

7 years ago
Assignee: server-ops → dgherman
(Assignee)

Comment 2

7 years ago
We can enable the debug logging in Jira to see exactly what's failing, the initial check or the ldap auth.
http://confluence.atlassian.com/display/JIRA042/Integrating+JIRA+with+LDAP

bottom section Cannot authenticate against LDAP password
(Reporter)

Comment 3

7 years ago
Turns out I was consistently typing a wrong character in the password, which is  embarrassing but at least makes sense.

I must have selected the option to remember password in mozilla intranet at some point, which is why I was able to login even when typing a wrong password in the login form (from the login link). 

Only found this when finally remembered to use firefox in private mode. 
Thanks for the help, sorry for the wasted time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.