[WT] Create new ad report that includes page data

RESOLVED DUPLICATE of bug 666319

Status

www.mozilla.org
General
P1
normal
RESOLVED DUPLICATE of bug 666319
7 years ago
6 years ago

People

(Reporter: Laura Forrest, Assigned: Laura Forrest)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
As you an see in the "Onsite Ad Clickthrough" report in the Mozilla.com 50% profile, we've implemented ad tracking on various parts of our site. That report isn't as useful as it could be since it doesn't include page data. Please create a report that shows the same info, by page URL. 

This falls into our overarching goal to gain a better understanding of what interests our site visitors the most.

Comment 1

7 years ago
I have created a test report entitled Onsite Ad Clickthroughs by Page in the Mozilla.com (50%) profile.  This report should begin populating later this evening.  I will be reviewing it tomorrow morning.

Comment 2

7 years ago
The Onsite Ad Clickthrough by Page report has begun to populate.  The first dimension represents the referring page (per hit) field, the second value is the value for parameter for WT.ac.

The reason referring page (per hit) was used as the primary dimension is because the WT.ac parameter populates the hit on the 'landing' page.  Meaning that if a user clicks on a 'download' link from www.google.com, the resulting hit would be similar to the following:

URL (of current page), referring URL, WT.ac
www.mozilla.com/en-US/mobile/download/, www.google.com/, download

or for example if a user was already on the mozilla site:

URL (of current page), referring URL, WT.ac
www.mozilla.com/en-US/mobile/download/, www.mozilla.com/en-US/firefox/3.6.17/whatsnew/, download

Please review the report and let me know if it makes sense.
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> The Onsite Ad Clickthrough by Page report has begun to populate.  The first
> dimension represents the referring page (per hit) field, the second value is
> the value for parameter for WT.ac.
> 
> The reason referring page (per hit) was used as the primary dimension is
> because the WT.ac parameter populates the hit on the 'landing' page.  Meaning
> that if a user clicks on a 'download' link from www.google.com, the resulting
> hit would be similar to the following:
> 
> URL (of current page), referring URL, WT.ac
> www.mozilla.com/en-US/mobile/download/, www.google.com/, download
> 
> or for example if a user was already on the mozilla site:
> 
> URL (of current page), referring URL, WT.ac
> www.mozilla.com/en-US/mobile/download/,
> www.mozilla.com/en-US/firefox/3.6.17/whatsnew/, download
> 
> Please review the report and let me know if it makes sense.

I'm looking at it now and the referring pages make it a bit confusing. I was hoping for something along the lines of:

Page | Ad Title | Clicks | CTR

If there's another type of tagging we should be using to get this basic information, then let's do it.
(Assignee)

Comment 4

7 years ago
Looks like Brad reconfigured a new report and I'll check that to see if that works.

Comment 5

7 years ago
Take a look at the Onsite Ad Clickthrough report I believe it's configured correctly.
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> Take a look at the Onsite Ad Clickthrough report I believe it's configured
> correctly.

Looks like the same thing is still happening as in Comment 3 (showing referring pages). Brad - what do you recommend for next steps?

Comment 7

7 years ago
While the report help info for the Page dimension states that it’s the ‘referring site’, it is not actually the ‘referrer’ field.  Each page record contains what you expect, the page in which the ad click-through took place.

Comment 8

7 years ago
I did some research/testing on this report and it turns out that the standard onsite ad tracking reports (the one that uses WT.ac and WT.ad) as parameters is 'hard-coded' by our analysis engine.  Therefore, we will need to use the custom WT.z_ad_name and WT.z_ad_event parameters in order to build this report to include the page dimension.
(Assignee)

Comment 9

7 years ago
Next steps here are to add the proper tagging to one page to test and see if this works, then generate a report to see how that works. 

Let's do that for the /new landing page. Laura to file new bug for that.
(Assignee)

Updated

7 years ago
Assignee: brad.gross → lforrest
(Assignee)

Comment 10

7 years ago
Since the /new page will change shortly I'm exploring alternates.
(Assignee)

Updated

7 years ago
Priority: -- → P1
(Assignee)

Comment 11

7 years ago
Automatic Link Tracking should do this automatically, which will be a lot more scalable than manual tagging each campaign launch. Marking this bug as a dup of Bug 666319
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666319
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.