On Linux, profileserver.py looks for firefox binary in dist/firefox instead of dist/bin

RESOLVED INVALID

Status

()

Core
Build Config
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I'm probably doing something wrong here, but when I run

  OBJDIR=. python _profile/pgo/profileserver.py

I get

args: ['/build/jlebar/moz/ff-1/valgrind/dist/firefox/firefox-bin', '-no-remote', '-profile', '/build/jlebar/moz/ff-1/valgrind/_profile/pgo/pgoprofile/', 'http://localhost:8888/index.html']
Traceback (most recent call last):
  File "_profile/pgo/profileserver.py", line 92, in <module>
    timeout = None)
  File "/build/jlebar/moz/ff-1/valgrind/_profile/pgo/automation.py", line 849, in runApp
    stderr = subprocess.STDOUT)
  File "/build/jlebar/moz/ff-1/valgrind/_profile/pgo/automation.py", line 173, in __init__
    universal_newlines, startupinfo, creationflags)
  File "/usr/lib/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1141, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory


From the first line of the output, it looks like automation.py is looking in dist/firefox for firefox-bin, while the binary actually lives in dist/bin.  When I make a symlink from dist/bin to dist/firefox, the script runs fine.

(To the question of why I'm doing this in the first place: My build crashed on tryserver during the profile step of PGO, and I was trying to reproduce.)
Don't we package before PGO?  That would get you your app in dist/firefox ...

Comment 2

7 years ago
profileserver runs on the packaged build, which ends up in dist/firefox. Run `make package`. This is becasue profiling needs omnijar in order to do its job.
Per comments 1 and 2.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.