[kitsune] about 90% of the time Firefox Help is shown instead of Thunderbird Help

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: rolandtanglao, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Sancus believes it a problem with one of the webheads having issues with its gettext files

If you get .51 it shows Thunderbird, if you get .52 it shows Firefox

Steps to reproduce:
1. https://support.mozillamessaging.com/en-US/forums/site-issues/2?last=2
2. Hit Control or Command R repeatedly to refresh the page and you will see the problem
(Assignee)

Comment 1

8 years ago
Created attachment 528997 [details] [diff] [review]
Diff between expected and wrong output

And this is certainly not something hapenning on the front-end caches. For some reason, sumomo itself is not always returning the same content.

Andrei, could this be some l10n problem when the cron job updates stuff? Something like reverting to defaults when our stuff is being updated or something like that ?
andym has a fix as pointed out in bug 656681
soooo we'll wait for a proper fix as opposed to forking for no reason :-) !
Depends on: 656681
unfortunately it looks like the proper fix is going to be a wee bit slower than we'd like, so sancus and gozer please apply one liner (or monkey patch) and then after confirming it works, i'll remove bug 656681  as a dependency, close this bug and open a new "proper fix" bug with bug 655681 as a dependency
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.