Add New Version compatibility checker does not catch incorrect GUID

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: ehume, Assigned: andy+bugzilla)

Tracking

unspecified
6.0.10
x86
Windows 7

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: current Moz Update as of today

Tonight I uploaded new versions of Aeon, Aeon Clouds and Aeon Colors. When I came to Aeon Colors, I accidentally selected the Aeon Clouds online section to which I uploaded my Aeon Color file.

The Add A New Version compatibility checker cleared the Aeon Colors file for Aeon Clouds. Had I not thought "Hey, wait a minute. I better check," Lord knows what would have happened. The compatibility checker dialog window obscures the name of the Add-On entry, so you can't see what section you are in.

The themes have different GUID's as well as different names, different internal names, and different jarfile names.

Reproducible: Always

Steps to Reproduce:
1. Select an Add-on to update a version. Call it Addon-A.
2. Upload an file for a different Add-on. Call it Addon-B.
3. Run the compatibility checker.

Actual Results:  
The compatibility checker found no errors..

Expected Results:  
The compatibility checker should have told me I was attempting to upload an incorrect addon.

The old AMO and earlier sites used to catch this kind of mistake. I know that from personal experience.
There's a step in the upload process where we check the ID and make sure it's the same. I'll let somebody else confirm this, but I think this bug is INVALID.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Q2 2011
andym to double check
Assignee: nobody → amckay
Priority: -- → P4
Target Milestone: Q2 2011 → 6.0.10
The check is in zamboni but not in the validator since the validator does not know about the database and the add-on's metadata.
(Assignee)

Comment 4

8 years ago
Created attachment 531465 [details]
different uuid
(Assignee)

Comment 5

8 years ago
Works for me. The initial validation check passes as within itself, its all good. Then when you click add version, it does the AMO checks. I get the attached screenshot and I can't upload the addon. The flow could be improved, but this works for me.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.