Added a new bookmark, started sync - but bookmark won't appear on the server

RESOLVED DUPLICATE of bug 652122

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED DUPLICATE of bug 652122
7 years ago
7 years ago

People

(Reporter: dasschwarzeloch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Sync 1.7, Firefox 4.0.1

I already reset the server information from a different client (Sync 1.7, Firefox 3.6.16 there) and reset the current client with the server data.
Then added a bookmark locally and started sync.
4 Log-entries appear:

1304076982118	Engine.Bookmarks	WARN	Error creating record: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsINavHistoryQueryResultNode.childCount] Stack trace: BStore_getChildren()@resource://services-sync/engines/bookmarks.js:1431 < BStore_getChildren()@resource://services-sync/engines/bookmarks.js:1434 < BStore_getChildren()@resource://services-sync/engines/bookmarks.js:1434 < BStore_getAllIDs()@resource://services-sync/engines/bookmarks.js:1458 < resource://services-sync/engines/bookmarks.js:277 < _createRecord()@resource://services-sync/engines/bookmarks.js:408 < SyncEngine__uploadOutgoing()@resource://services-sync/engines.js:897 < SyncEngine__sync()@resource://services-sync/engines.js:968 < wrappedSync()@resource://services-sync/util.js:193 < batchedSync()@resource://services-sync/util.js:199 < WrappedNotify()@resource://services-sync/util.js:172 < Engine_sync()@resource://services-sync/engines.js:377 < WeaveSvc__syncEngine()@resource://services-sync/service.js:1913 < resource://services-sync/service.js:1793 < WrappedNotify()@resource://services-sync/util.js:172 < WrappedLock()@resource://services-sync/util.js:140 < _lockedSync()@resource://services-sync/service.js:1695 < resource://services-sync/service.js:1686 < WrappedCatch()@resource://services-sync/util.js:114 < sync()@resource://services-sync/service.js:1667 < browser.js:5320

----

1304076982120	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("menu")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync()@service.js:1667 < (3)@browser.js:5320

----

1304076982121	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("x8aSZJWet5ne")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync()@service.js:1667 < (3)@browser.js:5320

----

1304076982122	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("AYa2XXgTtbFu")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync()@service.js:1667 < (3)@browser.js:5320


Reproducible: Always

Steps to Reproduce:
See details

Comment 1

7 years ago
I've got this one as well. It occurs on a clean install of Firefox 4, Ubuntu version with a new Sync account. I have disabled FIPS and enabled logging and here are the last few lines of the log:


(many WARN lines like these next five)
1304715079893	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("hXny-7bA7f8E")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync(false)@service.js:1667 < ([object Object])@service.js:596 < notify([object XPCWrappedNative_NoHelper])@util.js:1185
1304715079894	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("VNDJJUfNWx4a")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync(false)@service.js:1667 < ([object Object])@service.js:596 < notify([object XPCWrappedNative_NoHelper])@util.js:1185
1304715079895	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("pZE_yVoYw6sr")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync(false)@service.js:1667 < ([object Object])@service.js:596 < notify([object XPCWrappedNative_NoHelper])@util.js:1185
1304715079896	Engine.Bookmarks	WARN	Error creating record: this._lazyMap is not a function JS Stack trace: _createRecord("hVVYrZ5LAfyU")@bookmarks.js:408 < SyncEngine__uploadOutgoing()@engines.js:897 < SyncEngine__sync()@engines.js:968 < wrappedSync(null)@util.js:193 < batchedSync()@util.js:199 < WrappedNotify()@util.js:172 < Engine_sync()@engines.js:377 < WeaveSvc__syncEngine([object Object])@service.js:1913 < ()@service.js:1793 < WrappedNotify()@util.js:172 < WrappedLock()@util.js:140 < _lockedSync()@service.js:1695 < ()@service.js:1686 < WrappedCatch()@util.js:114 < sync(false)@service.js:1667 < ([object Object])@service.js:596 < notify([object XPCWrappedNative_NoHelper])@util.js:1185
1304715079897	Engine.Bookmarks	INFO	Uploading last batch of 529 records
1304715079897	Collection	DEBUG	POST Length: 2
1304715080209	Collection	DEBUG	POST success 200 https://scl2-sync422.services.mozilla.com/1.0/a5iobwh4ltupwzy7ckpzm4rhu2zhcuop/storage/bookmarks
1304715080228	Engine.Forms	INFO	0 outgoing items pre-reconciliation
1304715080228	Engine.Forms	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1304715080328	Engine.History	INFO	1 outgoing items pre-reconciliation
1304715080328	Engine.History	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1304715080331	Engine.History	INFO	Uploading all of 1 records
1304715080332	Collection	DEBUG	POST Length: 481
1304715080679	Collection	DEBUG	POST success 200 https://scl2-sync422.services.mozilla.com/1.0/a5iobwh4ltupwzy7ckpzm4rhu2zhcuop/storage/history
1304715080682	Engine.Passwords	INFO	0 outgoing items pre-reconciliation
1304715080683	Engine.Passwords	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1304715080684	Engine.Prefs	INFO	0 outgoing items pre-reconciliation
1304715080685	Engine.Prefs	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1304715080686	Engine.Tabs	INFO	1 outgoing items pre-reconciliation
1304715080687	Engine.Tabs	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1304715080700	Engine.Tabs	INFO	Uploading all of 1 records
1304715080700	Collection	DEBUG	POST Length: 1168
1304715081119	Collection	DEBUG	POST success 200 https://scl2-sync422.services.mozilla.com/1.0/a5iobwh4ltupwzy7ckpzm4rhu2zhcuop/storage/tabs
1304715081132	Service.Main	CONFIG	Starting backoff, next sync at:Fri May 06 2011 23:07:32 GMT+0100 (BST)
1304715081133	Service.Main	DEBUG	Exception: Some engines did not sync correctly No traceback available

Comment 2

7 years ago
I should add (though I'm double posting, sorry) that the log messages are accompanied by a very persistent Status Bar message:

"Sync encountered an error while synchronising: Unknown error. Sync will automatically retry this action. [Sync Now]"
The original reporter's problem looks identical to Bug 652122.

James, if you see the same 

  Error creating record: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsINavHistoryQueryResultNode.childCount]

Then we'll leave this in the same bug and dupe. Otherwise, please file a new bug.

The issue, as explained in Bug 652122, is that Sync and Places don't play well together with folder queries. The only workaround is to remove whichever items are causing the error, which we can figure out by enabling Trace logging for the bookmarks engine.

Comment 4

7 years ago
I'll file afresh as I don't have that error code anywhere in my log. Here's the only "Encountered exception: Component returned failure code":


1304715793475	Engine.Bookmarks	INFO	529 outgoing items pre-reconciliation
1304715794625	Engine.Bookmarks	WARN	Failed to reconcile incoming record 2TBaoq3OG5On
1304715794625	Engine.Bookmarks	WARN	Encountered exception: Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsINavBookmarksService.getBookmarkURI] Stack trace: resource://services-sync/engines/bookmarks.js:293 < _findDupe()@resource://services-sync/engines/bookmarks.js:418 < SyncEngine__reconcile()@resource://services-sync/engines.js:846 < resource://services-sync/engines.js:659 < resource://services-sync/record.js:813 < Channel_onDataAvail()@resource://services-sync/resource.js:530
1304715794627	Engine.Bookmarks	WARN	Failed to reconcile incoming record CjvGhHB61lDi

Thanks!
J.
Duping this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 652122
You need to log in before you can comment on or make changes to this bug.