The Update procedure is a headache; restarts the browser without warning, potentially resulting in data loss.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: algotechie, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Before version 4, the update process used to warn me that a restart of the browser is necessary to apply the updates and provide me options to restart just then or later. Today, I got prompted to update to version 4.0.1 from version 4. I started the update from Help menu>About. There are three things I'd complain about:

1. The size of the update (the data being downloaded for updating) is bigger than the size of the full installer! What's the use of such an update? An update means only those components be downloaded which have been changed; they must be compressed in such a way that their download size is less than the full installer. Otherwise the in-application update is a joke; it's better to download the full installer and overwrite the existing installation.

2. After downloading the update, the About box presents me with a button with the caption "Apply Updates"; there's no mention of a browser restart. I was at that time downloading a file and the download was non-resumable. On seeing no warning, I thought the updates in this version probably do not require a restart. And therefore clicked the button "Apply Update". Bam! The download was gone!! That file was more important to my work than the browser update. And of course we have a slow connection at the work place. It had to be downloaded again. If a user is typing something in an online form (an email, comment, blog post, report, whatever), or is in the middle of uploading something, that data would also be gone. There must be a warning before restarting the browser, otherwise it's no different from a browser crash. The warning is what makes a planned restart different from a crash.

3. The about box remains in the user's face for as long as the update is being downloaded. There's no minimize or hide button. And it pauses the downloading if it's closed. It stays on top of the browser window and obstructs the web pages. It would be great if a "minimize to tray" button is provided on the About box when it's downloading the updates.

Reproducible: Always

Steps to Reproduce:
1. Wait till a new version of the browser is available for Firefox 4.0.
2. Go to Help menu>About Firefox; click "Check for updates".

Actual Results:  
1. Size of the update is bigger than the full standalone installer.
2. After the download is complete, there's a button "Apply Updates" which would restart the browser without warning. It's not clear what would happen if the About box is closed at this point.
3. You cannot view the whole web page as the About box stays on the top.

Expected Results:  
1. The size of the update should be smaller than the full installer.
2. There must be a warning before restarting the browser, with an option to restart later.
3. There should be a "minimize to tray" or "continue in background" button on the About box when it's downloading the updates.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Updated

7 years ago
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: 4.0 Branch → 2.0 Branch
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101
> Firefox/4.0.1
> Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101
> Firefox/4.0.1
> 
> Before version 4, the update process used to warn me that a restart of the
> browser is necessary to apply the updates and provide me options to restart
> just then or later. Today, I got prompted to update to version 4.0.1 from
> version 4. I started the update from Help menu>About. There are three things
> I'd complain about:
The warn before restart is actually controlled by Firefox and not application update (application update performs a call that is observed by Firefox code and that code chooses whether to warn or not) so moving to Firefox -> General.

> 1. The size of the update (the data being downloaded for updating) is bigger
> than the size of the full installer! What's the use of such an update? An
> update means only those components be downloaded which have been changed;
> they must be compressed in such a way that their download size is less than
> the full installer. Otherwise the in-application update is a joke; it's
> better to download the full installer and overwrite the existing
> installation.
The installer's compression is heavily optimized and uses lzma. This part of your bug report is Bug 641212.

> 2. After downloading the update, the About box presents me with a button
> with the caption "Apply Updates"; there's no mention of a browser restart. I
> was at that time downloading a file and the download was non-resumable. On
> seeing no warning, I thought the updates in this version probably do not
> require a restart. And therefore clicked the button "Apply Update". Bam! The
> download was gone!! That file was more important to my work than the browser
> update. And of course we have a slow connection at the work place. It had to
> be downloaded again. If a user is typing something in an online form (an
> email, comment, blog post, report, whatever), or is in the middle of
> uploading something, that data would also be gone. There must be a warning
> before restarting the browser, otherwise it's no different from a browser
> crash. The warning is what makes a planned restart different from a crash.
That is a Firefox bug in that the about dialog is Firefox ui and the strings are controlled by Firefox. Also, I believe that text has been fixed in the nightly builds recently.

> 3. The about box remains in the user's face for as long as the update is
> being downloaded. There's no minimize or hide button. And it pauses the
> downloading if it's closed. It stays on top of the browser window and
> obstructs the web pages. It would be great if a "minimize to tray" button is
> provided on the About box when it's downloading the updates.
Also Firefox ui and not application update.

In the future, please limit your bug reports to one issue. Thanks
Component: Application Update → General
Product: Toolkit → Firefox
QA Contact: application.update → general
(Reporter)

Comment 2

7 years ago
No problems with the changes you or the others made but just FYKI, it was someone else who changed those things. When I reported the bug, the things were looking just as they do right now (because those are the only ones I know about, I skipped the documentation).

You're right about putting a single issue inside one bug. Thanks for the suggestion.

Okay, so as you mentioned, the 2nd issue will hopefully be gone in a future version. The 1st one still remains (I read the bug you pointed to and it was inconclusive so far). The 3rd one is less important to me but still an inconvenience nevertheless.
Duplicate of this bug: 691015
algotechnie, does your issue still apply in Firefox 10?
Version: 2.0 Branch → 4.0 Branch
(Reporter)

Comment 5

6 years ago
I've not been able to update to version 10. Here's what happened.

A few days back I got the slide notification of the availability of version 10 and accepted to update. It showed a 10 MB update download. After downloading about 8 MB, it started from 0 again and this time showed 18.8 MB to be downloaded. This time, after about 18 MB download was complete, it displayed the error message saying that the update failed and I should download the installer. I thought it better to wait for the next version.

After a day or two, I received another notification of the availability of the next point release (version 10.0.1 or something; just a point ahead of the original version 10). I allowed it to perform the update. This time it showed 18.8 MB to be downloaded. After about 16 MB had been downloaded, it started the download from 0 MB again automatically. It then downloaded the 18.8 MB data fully and proceeded on to installing the update. Within a second, it showed the same error message (viz, update failed, download and install from the site).

So right now, I'm waiting for the next release (10.0.2 or 10.0.3 or 11.0 or whatever).
(Reporter)

Comment 6

6 years ago
And oh, my current version is 9.0.1.

Comment 7

4 years ago
Do you still see this problem when using a current version?
Flags: needinfo?(linotechie)
Whiteboard: [closeme 2014-03-01]
(Reporter)

Comment 8

4 years ago
Hi Wayne, my current version is 27 and since many a version ago, I've been downloading the full installer and then running it. I've never done the in-app update for a long time. So can't say if those issues are still present. However, some of my friends do have auto-updates enabled and it's going on smoothly for them. Guess I can say I'm okay with the current setup procedure.
Flags: needinfo?(linotechie)

Comment 9

4 years ago
Thanks for the update.
In future, when you no longer see the bug, you can change the status to resolved, and resolutino to WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2014-03-01]
You need to log in before you can comment on or make changes to this bug.