Quote spacing broken in italic text

RESOLVED DUPLICATE of bug 589682

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 589682
8 years ago
4 years ago

People

(Reporter: fortressmaximus05, Unassigned)

Tracking

({regression})

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Quotes are not displayed properly in italics, as they appear on other characters and adjacent spaces are ignored.

Reproducible: Always

Steps to Reproduce:
1. go to any page with italic quotes
2.
3.

Actual Results:  
Spaces are ignored, quotes are on other characters

Expected Results:  
Quotes display correctly, not remove spaces
This is a regression in Firefox 4.0.1; it does not happen in 4.0. I'll add some pictures.
Version: unspecified → 4.0 Branch
This is a screenshot of the following HTML:

<p>
Hello "the" world!<br>
<em>Hello "the" world!</em><br>
Hello "the"| world!<br>
<em>Hello "the"| world!</em><br>
</p>
It does NOT happen in Aurora (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110429 Firefox/5.0a2) as best I can tell.
I've added the html James posted to the example link, and it's rendering differently. Still wrong, though.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589682
For posterity: This is a bug of "Times New Roman" font and fixed in Fx5
You need to log in before you can comment on or make changes to this bug.