Browser becomes sluggish during normal usage, memory footprint increases dramatically, followed by a crash. OOM. Empty Crash Report

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: incarnate, Unassigned)

Tracking

({crash, stackwanted})

4.0 Branch
x86_64
Windows 7
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

During regular browser usage, I occasionally experience a sudden sluggishness to the browser, followed by significant increases in memory usage (I have watched it go from 900MB to 2GB in about 5 minutes), followed by a crash. I have experienced this since 4.0. I am now attempting to disable my plugins to reduce the chances of crashing, which may diminish reproducibility. However, prior to this point I would find my browser crashed every day or two. My system is always-on, and when returning to it, the browser would often have died while I was away.

I have never been able to correlate the crashes with any particular plugin or type of site. I have experienced issues on everything from craigslist to ebay to other random sites.

Reproducible: Sometimes

Steps to Reproduce:
I cannot reproduce this on-demand. The issue would present over a period of uptime (usually in the 8-24 hour range). My own reproducibility may not be diminished with disabling of many plugins and addons.



quad-core Athlon, raid1 disks. System has relatively light web and email usage for the most part. Entirely stable, uptimes in months, only rebooted for major system updates.
Version: unspecified → 4.0 Branch
Maybe getting Stacks via Windbg is better since those Reports are empty?!
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Keywords: stackwanted

Updated

8 years ago
Severity: major → critical
Summary: Browser becomes sluggish during normal usage, memory footprint increases dramatically, followed by a crash. → Browser becomes sluggish during normal usage, memory footprint increases dramatically, followed by a crash. OOM. Empty Crash Report
These problems are fixed with newer versions of Firefox.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 4

7 years ago
(In reply to Marco Castelluccio from comment #3)
> These problems are fixed with newer versions of Firefox.

mar.castelluccio, 
precisely how did you test this, or what bug(s) fixed this?
(In reply to Wayne Mery (:wsmwk) from comment #4)
> (In reply to Marco Castelluccio from comment #3)
> > These problems are fixed with newer versions of Firefox.
> 
> mar.castelluccio, 
> precisely how did you test this, or what bug(s) fixed this?

The recent improvements in MemShrink. However the report lacks also informations.

Comment 6

7 years ago
(In reply to Marco Castelluccio from comment #5)
> (In reply to Wayne Mery (:wsmwk) from comment #4)
> > (In reply to Marco Castelluccio from comment #3)
> > > These problems are fixed with newer versions of Firefox.
> > 
> > mar.castelluccio, 
> > precisely how did you test this, or what bug(s) fixed this?
> 
> The recent improvements in MemShrink. However the report lacks also
> informations.

while it's true memshrink has driven improvements, the fate of specific bugs should be not be changed without testing, or strong correlating information, and/or asking for feedback from the bug reporter.

In the case of this bug:
- it's a recent report, so the reporter is still likely to respond to feedback
- comment 1, although not the original reporter, has URLs in the crash reports
- *if* it were decided that there is not enough information and the reporter isn't responding (and there has been no testing) then the correct resolution for the bug is incomplete, not WORKSFORME.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

7 years ago
incarnate, Richard, can you reproduce this is safe mode using version 9 (nightly)?  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Backup your profile before testing.

(I'm uncertain anything of significance from memshrink has landed in v7 or v8 - found at http://www.mozilla.org/en-US/firefox/channel/ )
I closed it because the crash reports have been empty for four months, there was no activity on the bug for four months, and there aren't enough informations (I didn't see the URLs in the crash reports, and still not see them). I should have closed it as INCOMPLETE, you're right!
However if you think this is actually a useful bug, we can add it to [MemShrink].
(Reporter)

Comment 9

7 years ago
Hi there. By disabling most of the plugins in my browser shortly after the original report, I found the memory leak to be either substantially reduced or eliminated entirely.

There are no crash reports with the bug because they were not being produced during/after the memory-explosion scenarios (I worked with Richard to try and get it to generate a crash report at the time, without luck). I could have attempted to run a debug build, with the plugins enabled; but my work schedule at the time made more extensive testing (along with having an unstable primary browser) somewhat problematic.

I have very occasionally still experienced unusual memory allocation and sluggish behaviour, even in FF6; but this has only happened once, and reproducing the issue may be problematic.

If desired, I can try to re-enable all plugins in FF6, and see what ensues over general usage. Of course, the browser version is now different (some plugins may be incompatible or upgraded), and so on, but I'll try it if that would be helpful.

Comment 10

7 years ago
Richard's crashes of comment 1 have URLs, but you must be logged in to crash-stats to see them. I tested them, encountered no problem, but the crashes occurred 12-20 hours after startup, so it's unlikely I can reproduce his conditions. 

But this is incarnate's bug, and Comment 9 indicates plugins or addons are involved. Among the options
1. close incomplete and if problem recurs, reopen the bug. 
2. leave open and incarnate tests soon. but perhaps it could be a FF newer than FF6, like 7 (beta) or 8 (alpha)?
3. list your plugins and someone can give an opinion on which one(s) might be causing trouble, and whether it's something fixable in FF

Comment 11

7 years ago
incarnate tells me the major remaining problem (with no addons) appears to be flash related
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.