Last Comment Bug 653888 - JSON Walk algorithm should be able to delete properties from parsed arrays
: JSON Walk algorithm should be able to delete properties from parsed arrays
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
javascript: alert(JSON.parse("[1]", f...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-29 20:07 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-05-17 17:51 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch with test (10.52 KB, patch)
2011-04-29 20:07 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
paul.biggar: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-04-29 20:07:03 PDT
Created attachment 529258 [details] [diff] [review]
Patch with test

Was doing a last bit of cleanup here since most of the rest of the code is well-examined for spec compliance issues, turns out there's a little bit to go still -- good thing I looked.
Comment 1 Paul Biggar 2011-05-04 07:42:25 PDT
Comment on attachment 529258 [details] [diff] [review]
Patch with test

Review of attachment 529258 [details] [diff] [review]:

The only comment I'd have here is that it would be good to use variable names from the spec, like 'val' and 'keys'.
Comment 2 Paul Biggar 2011-05-04 07:43:07 PDT
Oh, and I forgot to say, this didn't apply for me, so I havent checked that this works.
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-04 13:34:09 PDT
Nope, it's atop a bunch of other patches locally (some of which you just reviewed).  That's not uncommon; in general, if you want something to test and the patch doesn't work, ping me on IRC for a patch bundle.
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-05-10 15:11:10 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/83ae6e7c572e
http://hg.mozilla.org/mozilla-central/rev/50fe7f87c01a (backout)
Note: not marking as fixed because last changeset is a backout.
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-11 10:23:20 PDT
http://hg.mozilla.org/tracemonkey/rev/3ba391aa3130
Comment 6 Chris Leary [:cdleary] (not checking bugmail) 2011-05-14 17:23:53 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/3ba391aa3130
Comment 7 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-17 17:51:57 PDT
Per comment 6 (bot bug?).

Note You need to log in before you can comment on or make changes to this bug.