If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't build on OS X 10.5 after bug 640494 landing

RESOLVED DUPLICATE of bug 653777

Status

()

Core
JavaScript Engine
--
blocker
RESOLVED DUPLICATE of bug 653777
7 years ago
7 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
STR:
1. hg up -r 83e8315c5f69
2. rm -rf ../fx
3. export MOZ_OBJDIR=../fx && make  -f client.mk build

Actual:

jsapi.cpp
g++-4.2 -o jsapi.o -c  -fvisibility=hidden -DOSTYPE=\"Darwin9.8.0\" -DOSARCH=Darwin -DEXPORT_JS_API -D__STDC_LIMIT_MACROS -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".dylib\" -Ictypes/libffi/include -I.  -I/Users/philor/mc/mozilla/js/src -I. -I./../../dist/include -I./../../dist/include/nsprpub  -I/Users/philor/mc/fx/dist/include/nspr   -I/Users/philor/mc/mozilla/js/src -I/Users/philor/mc/mozilla/js/src/assembler -I/Users/philor/mc/mozilla/js/src/yarr  -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -fno-strict-aliasing -fpascal-strings -fno-common -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -fstrict-aliasing -fno-stack-protector -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1   -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jsapi.pp /Users/philor/mc/mozilla/js/src/jsapi.cpp
{standard input}:6798:non-relocatable subtraction expression, "LC3" minus "L00000000018$pb"
{standard input}:6798:symbol: "L00000000018$pb" can't be undefined in a subtraction expression
{standard input}:unknown:Undefined local symbol L00000000018$pb
make[5]: *** [jsapi.o] Error 1
make[4]: *** [libs_tier_js] Error 2
make[3]: *** [tier_js] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653777
You need to log in before you can comment on or make changes to this bug.