Allowing websites to disable zoom via viewport meta-tag is a usability issue.

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: CoJaBo-Bugzilla, Unassigned)

Tracking

Trunk
Other
Android

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 4.0.1

There needs to be an option or pref to override this, or Firefox should just ignore it outright by default.

Reproducible: Always

Steps to Reproduce:
Go to http://fukung.net/random (or some other mobile site that disables zoom)
Try to zoom to read text/images
(Reporter)

Updated

8 years ago
OS: Other → Android
Some time ago I filed bug 561202. That bug is a little more broad than this one, but probably basically the same.
I'm planning to write a Fennec add-on to add an option to ignore "user-scalable=no" and always allow zooming.  That might be a good place to experiment with any UI changes that could eventually be included in the browser.  I'll post an update here when the add-on is ready.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I agree that users should have an option to force zooming, but I think we still want to let pages disable zooming to support these use cases:

- Web pages must be able to override pinch zooming if they want to use multi-touch gestures for other purposes (for example, pinch to zoom a map in a web page, or a multi-touch painting app or game).

- Web pages must be able to override double-tap zooming if they want to respond to taps quickly, or to allow users to tap rapidly for other reasons (e.g. games).

when bug 603008 is fixed, then both these cases will be possible with touch events.  Maybe then we should encourage pages to use touch events and preventDefault to disable zooming, rather than "user-scalable=no".
Duplicate of this bug: 686363
For anyone looking, this was fixed in bug 707571. The pref is:

browser.ui.zoom.force-user-scalable
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.