eeks, tons of errors in navigator.js

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: HJ, Assigned: asa)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
WinNT4 build 2001011220

I guess there's another bug in navigator.js. Don't have that much time right
now, but will attache testcase. I can simply reproduce this bug with the
testcase. This might also be related to the cleanup of navigator.js.

1 - load testcase (make sure you have JS console active)
2 - use the link
3 - reload the attachement
4 - click on the green table cell and press enter
5 - move your mouse to different positions in the browser, and browser menu
Keep looking at your JS console. (line 31/81/1148 and line 870)

Sorry that I found this one. I hope this one will be fixed as quick as the other
navigator 'bug', that was just amazing!
(Reporter)

Comment 1

18 years ago
Created attachment 22551 [details]
Testcase/example
(Reporter)

Comment 2

18 years ago
Make sure to put that testcase on your local hard drive to trigger the bug!
I see this on linux as well.  Should this be DOM0 or event handling?
OS: Windows NT → All

Updated

18 years ago
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
Keywords: testcase

Comment 4

18 years ago
Marking NEW under DOM 0. Sorry if thats not the right place.

Comment 5

18 years ago
It should be fixed now.
(Reporter)

Comment 6

18 years ago
Yes, but what did fix this bug??
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
Hmmm guess what, I was confusing this with bug 65228 (I just looked at the
summary) and I remembed it was fixed so I just suggested this one was fixed too.
I guess I did well since it does appear to be fixed, but it was not the one I
thought it was! (do I make sense today? ;)
So no idea about what fixed it.
You need to log in before you can comment on or make changes to this bug.